aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-webadmin
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver/recipes-webadmin')
-rw-r--r--meta-webserver/recipes-webadmin/cockpit/cockpit_304.bb (renamed from meta-webserver/recipes-webadmin/cockpit/cockpit_220.bb)94
-rw-r--r--meta-webserver/recipes-webadmin/cockpit/files/0001-Warn-not-error-if-xsltproc-is-not-found.patch25
-rw-r--r--meta-webserver/recipes-webadmin/cockpit/files/0001-remove-tests-dep-on-gobject-intro.patch77
-rw-r--r--meta-webserver/recipes-webadmin/cockpit/files/0002-fix-makefile-use-copy-rule-for-unmodified-files.patch47
-rw-r--r--meta-webserver/recipes-webadmin/netdata/netdata/netdata.service12
-rw-r--r--meta-webserver/recipes-webadmin/netdata/netdata_1.44.3.bb81
-rw-r--r--meta-webserver/recipes-webadmin/netdata/netdata_git.bb55
-rw-r--r--meta-webserver/recipes-webadmin/webmin/files/disable-version-check.patch2
-rw-r--r--meta-webserver/recipes-webadmin/webmin/files/init-exclude.patch16
-rw-r--r--meta-webserver/recipes-webadmin/webmin/files/media-tomb.patch4
-rw-r--r--meta-webserver/recipes-webadmin/webmin/files/mount-excludefs.patch2
-rw-r--r--meta-webserver/recipes-webadmin/webmin/files/mysql-config-fix.patch2
-rw-r--r--meta-webserver/recipes-webadmin/webmin/files/net-generic.patch10
-rw-r--r--meta-webserver/recipes-webadmin/webmin/files/proftpd-config-fix.patch2
-rw-r--r--meta-webserver/recipes-webadmin/webmin/files/remove-startup-option.patch12
-rw-r--r--meta-webserver/recipes-webadmin/webmin/files/samba-config-fix.patch2
-rw-r--r--meta-webserver/recipes-webadmin/webmin/webmin_1.850.bb26
17 files changed, 210 insertions, 259 deletions
diff --git a/meta-webserver/recipes-webadmin/cockpit/cockpit_220.bb b/meta-webserver/recipes-webadmin/cockpit/cockpit_304.bb
index f06588a75a..df7f47a118 100644
--- a/meta-webserver/recipes-webadmin/cockpit/cockpit_220.bb
+++ b/meta-webserver/recipes-webadmin/cockpit/cockpit_304.bb
@@ -1,25 +1,25 @@
SUMMARY = "Admin interface for Linux machines"
DESCRIPTION = "Cockpit makes it easy to administer your GNU/Linux servers via a web browser"
-LICENSE = "LGPLv2.1"
+LICENSE = "LGPL-2.1-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
SRC_URI += " \
https://github.com/cockpit-project/cockpit/releases/download/${PV}/cockpit-${PV}.tar.xz \
- file://0001-remove-tests-dep-on-gobject-intro.patch \
- file://0002-fix-makefile-use-copy-rule-for-unmodified-files.patch \
+ file://0001-Warn-not-error-if-xsltproc-is-not-found.patch \
file://cockpit.pam \
"
-SRC_URI[md5sum] = "beb88d8e70ee1da6ebd917c956217803"
-SRC_URI[sha256sum] = "afc82acc8ef9d51e0f34265a07a2f059f5b71a1df721b299e657a40a098cbb7f"
+SRC_URI[sha256sum] = "a87d090c930e2058bb3e970ca7f2bafe678687966b5c0b8b42a802977e391ce9"
inherit gettext pkgconfig autotools systemd features_check
+inherit ${@bb.utils.contains('PACKAGECONFIG', 'old-bridge', '', 'python3targetconfig', d)}
-DEPENDS += "glib-2.0-native intltool-native gnutls virtual/gettext json-glib krb5 libpam systemd"
+DEPENDS += "glib-2.0-native intltool-native gnutls virtual/gettext json-glib krb5 libpam systemd python3-setuptools-native"
+DEPENDS += "${@bb.utils.contains('PACKAGECONFIG', 'old-bridge', '', 'python3-pip-native', d)}"
-COMPATIBLE_HOST_libc-musl = "null"
+COMPATIBLE_HOST:libc-musl = "null"
-RDEPENDS_${PN} += "glib-networking"
+RDEPENDS:${PN} += "glib-networking"
REQUIRED_DISTRO_FEATURES = "systemd pam"
@@ -30,6 +30,7 @@ EXTRA_AUTORECONF = "-I tools"
EXTRA_OECONF = " \
--with-cockpit-user=${COCKPIT_USER_GROUP} \
--with-cockpit-group=${COCKPIT_USER_GROUP} \
+ --with-admin-group=${COCKPIT_USER_GROUP} \
--with-cockpit-ws-instance-user=${COCKPIT_WS_USER_GROUP} \
--with-cockpit-ws-instance-group=${COCKPIT_WS_USER_GROUP} \
--disable-doc \
@@ -38,12 +39,14 @@ EXTRA_OECONF = " \
PACKAGECONFIG ??= " \
${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)} \
+ old-bridge \
"
PACKAGECONFIG[pcp] = "--enable-pcp,--disable-pcp,pcp"
PACKAGECONFIG[dashboard] = "--enable-ssh,--disable-ssh,libssh"
PACKAGECONFIG[storaged] = ",,,udisks2"
PACKAGECONFIG[polkit] = "--enable-polkit,--disable-polkit,polkit"
+PACKAGECONFIG[old-bridge] = "--enable-old-bridge"
PACKAGES =+ " \
${PN}-pcp \
@@ -61,65 +64,74 @@ PACKAGES =+ " \
${PN}-playground \
${PN}-docker \
${PN}-dashboard \
+ ${PN}-packagekit \
+ ${PN}-apps \
${PN}-bridge \
${PN}-ws \
${PN}-desktop \
"
SYSTEMD_PACKAGES = "${PN}-ws"
-FILES_${PN}-pcp = " \
+FILES:${PN}-pcp = " \
${libexecdir}/cockpit-pcp \
${datadir}/cockpit/pcp \
${localstatedir}/lib/pcp/config/pmlogconf/tools/cockpit \
"
-FILES_${PN}-realmd = "${datadir}/cockpit/realmd"
-FILES_${PN}-tuned = "${datadir}/cockpit/tuned"
-FILES_${PN}-shell = "${datadir}/cockpit/shell"
-FILES_${PN}-systemd = "${datadir}/cockpit/systemd"
-FILES_${PN}-users = "${datadir}/cockpit/users"
-FILES_${PN}-kdump = " \
+FILES:${PN}-realmd = "${datadir}/cockpit/realmd"
+FILES:${PN}-tuned = "${datadir}/cockpit/tuned"
+FILES:${PN}-shell = "${datadir}/cockpit/shell"
+FILES:${PN}-systemd = "${datadir}/cockpit/systemd"
+FILES:${PN}-users = "${datadir}/cockpit/users"
+FILES:${PN}-kdump = " \
${datadir}/cockpit/kdump \
${datadir}/metainfo/org.cockpit-project.cockpit-kdump.metainfo.xml \
"
-FILES_${PN}-sosreport = " \
+FILES:${PN}-sosreport = " \
${datadir}/cockpit/sosreport \
${datadir}/metainfo/org.cockpit-project.cockpit-sosreport.metainfo.xml \
${datadir}/pixmaps/cockpit-sosreport.png \
"
-FILES_${PN}-storaged = " \
+FILES:${PN}-storaged = " \
${datadir}/cockpit/storaged \
${datadir}/metainfo/org.cockpit-project.cockpit-storaged.metainfo.xml \
"
-FILES_${PN}-networkmanager = "${datadir}/cockpit/networkmanager"
-RDEPENDS_${PN}-networkmanager = "networkmanager"
+FILES:${PN}-networkmanager = " \
+ ${datadir}/cockpit/networkmanager \
+ ${datadir}/metainfo/org.cockpit-project.cockpit-networkmanager.metainfo.xml \
+"
+RDEPENDS:${PN}-networkmanager = "networkmanager"
-FILES_${PN}-machines = " \
+FILES:${PN}-machines = " \
${datadir}/cockpit/machines \
${datadir}/metainfo/org.cockpit-project.cockpit-machines.metainfo.xml \
"
-FILES_${PN}-selinux = " \
+FILES:${PN}-selinux = " \
${datadir}/cockpit/selinux \
${datadir}/metainfo/org.cockpit-project.cockpit-selinux.metainfo.xml \
"
-FILES_${PN}-playground = "${datadir}/cockpit/playground"
-FILES_${PN}-docker = " \
+FILES:${PN}-playground = "${datadir}/cockpit/playground"
+FILES:${PN}-docker = " \
${datadir}/cockpit/docker \
${datadir}/metainfo/org.cockpit-project.cockpit-docker.metainfo.xml \
"
-FILES_${PN}-dashboard = "${datadir}/cockpit/dashboard"
-ALLOW_EMPTY_${PN}-dashboard = "1"
+FILES:${PN}-dashboard = "${datadir}/cockpit/dashboard"
+ALLOW_EMPTY:${PN}-dashboard = "1"
+
+FILES:${PN}-packagekit = "${datadir}/cockpit/packagekit"
+FILES:${PN}-apps = "${datadir}/cockpit/apps"
-FILES_${PN}-bridge = " \
+FILES:${PN}-bridge = " \
${bindir}/cockpit-bridge \
- ${libexec}/cockpit-askpass \
+ ${libexecdir}/cockpit-askpass \
+ ${PYTHON_SITEPACKAGES_DIR} \
"
-RDEPENDS_${PN}-bridge = ""
+RDEPENDS:${PN}-bridge = "${@bb.utils.contains('PACKAGECONFIG', 'old-bridge', '', 'python3', d)}"
-FILES_${PN}-desktop = "${libexecdir}/cockpit-desktop"
-RDEPENDS_${PN}-desktop += "bash"
+FILES:${PN}-desktop = "${libexecdir}/cockpit-desktop"
+RDEPENDS:${PN}-desktop += "bash"
-FILES_${PN}-ws = " \
+FILES:${PN}-ws = " \
${sysconfdir}/cockpit/ws-certs.d \
${sysconfdir}/pam.d/cockpit \
${sysconfdir}/issue.d/cockpit.issue \
@@ -129,6 +141,8 @@ FILES_${PN}-ws = " \
${systemd_system_unitdir}/cockpit.service \
${systemd_system_unitdir}/cockpit-motd.service \
${systemd_system_unitdir}/cockpit.socket \
+ ${systemd_system_unitdir}/cockpit-session.socket \
+ ${systemd_system_unitdir}/cockpit-session@.service \
${systemd_system_unitdir}/cockpit-wsinstance-http.socket \
${systemd_system_unitdir}/cockpit-wsinstance-http.service \
${systemd_system_unitdir}/cockpit-wsinstance-http-redirect.socket \
@@ -150,14 +164,14 @@ FILES_${PN}-ws = " \
${datadir}/cockpit/static \
${datadir}/cockpit/branding \
"
-CONFFILES_${PN}-ws += " \
+CONFFILES:${PN}-ws += " \
${sysconfdir}/issue.d/cockpit.issue \
${sysconfdir}/motd.d/cockpit \
"
-RDEPENDS_${PN}-ws += "openssl-bin"
-SYSTEMD_SERVICE_${PN}-ws = "cockpit.socket"
+RDEPENDS:${PN}-ws += "openssl-bin"
+SYSTEMD_SERVICE:${PN}-ws = "cockpit.socket"
-FILES_${PN} += " \
+FILES:${PN} += " \
${datadir}/cockpit/base1 \
${sysconfdir}/cockpit/machines.d \
${datadir}/polkit-1/actions/org.cockpit-project.cockpit-bridge.policy \
@@ -166,10 +180,14 @@ FILES_${PN} += " \
${datadir}/cockpit \
${datadir}/metainfo/cockpit.appdata.xml \
${datadir}/pixmaps/cockpit.png \
+ ${nonarch_libdir}/tmpfiles.d \
+ ${nonarch_libdir}/firewalld \
"
-RDEPENDS_${PN} += "${PN}-bridge"
+RDEPENDS:${PN} += "${PN}-bridge"
+# Needs bash for /usr/libexec/cockpit-certificate-helper
+RDEPENDS:${PN} += "bash"
-do_install_append() {
+do_install:append() {
pkgdatadir=${datadir}/cockpit
chmod 4750 ${D}${libexecdir}/cockpit-session
@@ -181,7 +199,7 @@ do_install_append() {
rm -rf ${D}${libdir}/firewalld
if ! ${@bb.utils.contains('PACKAGECONFIG', 'storaged', 'true', 'false', d)}; then
- for filename in ${FILES_${PN}-storaged}
+ for filename in ${FILES:${PN}-storaged}
do
rm -rf ${D}$filename
done
diff --git a/meta-webserver/recipes-webadmin/cockpit/files/0001-Warn-not-error-if-xsltproc-is-not-found.patch b/meta-webserver/recipes-webadmin/cockpit/files/0001-Warn-not-error-if-xsltproc-is-not-found.patch
new file mode 100644
index 0000000000..db583cfd29
--- /dev/null
+++ b/meta-webserver/recipes-webadmin/cockpit/files/0001-Warn-not-error-if-xsltproc-is-not-found.patch
@@ -0,0 +1,25 @@
+From 7c1f95995ce9180221bac03b7b1e1696b8a79de7 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 7 Sep 2022 11:12:28 -0700
+Subject: [PATCH] Warn not error if xsltproc is not found
+
+Upstream-Status: Inappropriate [oe-core specific]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 6896c19..2a1fb52 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -182,7 +182,7 @@ AC_SUBST([systemdunitdir], [$systemdunitdir])
+ # package as xgettext, and we find them by PATH, so just check for the one.
+ AC_PATH_PROG([XGETTEXT], [xgettext], [no])
+ if test "$XGETTEXT" = "no"; then
+- AC_MSG_ERROR([Please install gettext tools])
++ AC_MSG_WARN([Please install gettext tools])
+ fi
+
+ # ssh-add
diff --git a/meta-webserver/recipes-webadmin/cockpit/files/0001-remove-tests-dep-on-gobject-intro.patch b/meta-webserver/recipes-webadmin/cockpit/files/0001-remove-tests-dep-on-gobject-intro.patch
deleted file mode 100644
index 2242190a38..0000000000
--- a/meta-webserver/recipes-webadmin/cockpit/files/0001-remove-tests-dep-on-gobject-intro.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-From 788aace494f79e8201b18ebcdf1592b5030c5295 Mon Sep 17 00:00:00 2001
-From: Adrian Freihofer <adrian.freihofer@siemens.com>
-Date: Wed, 4 Dec 2019 17:23:46 +0100
-Subject: [PATCH] remove tests dep on gobject-intro
-
----
- src/ws/Makefile-ws.am | 54 ---------------------------------------------------
- 1 file changed, 54 deletions(-)
-
-diff --git a/src/ws/Makefile-ws.am b/src/ws/Makefile-ws.am
-index 009130941..34e13d7fe 100644
---- a/src/ws/Makefile-ws.am
-+++ b/src/ws/Makefile-ws.am
-@@ -246,60 +246,6 @@ EXTRA_DIST += \
-
- # ----------------------------------------------------------------------------------------------------
-
--noinst_PROGRAMS += test-server
--check_PROGRAMS += test-server
--
--GDBUS_CODEGEN_XML = $(srcdir)/src/ws/com.redhat.Cockpit.DBusTests.xml
--
--GDBUS_CODEGEN_GENERATED = \
-- src/ws/mock-dbus-tests.h \
-- src/ws/mock-dbus-tests.c \
-- $(NULL)
--
--# FIXME: --header/--body and --output are only available from GLib 2.56.
--# just use --generate-c-code and a bit of dependency ugliness for now
--GDBUS_CODEGEN_INVOCATION = \
-- $(AM_V_GEN) gdbus-codegen \
-- --interface-prefix com.redhat.Cockpit.DBusTests \
-- --c-namespace Test \
-- --c-generate-object-manager \
-- --generate-c-code src/ws/mock-dbus-tests \
-- $(GDBUS_CODEGEN_XML)
--
--BUILT_SOURCES += $(GDBUS_CODEGEN_GENERATED)
--CLEANFILES += $(GDBUS_CODEGEN_GENERATED)
--EXTRA_DIST += $(GDBUS_CODEGEN_XML)
--
--src/ws/mock-dbus-tests.h: $(GDBUS_CODEGEN_XML)
-- $(GDBUS_CODEGEN_INVOCATION)
--
--src/ws/mock-dbus-tests.c: $(GDBUS_CODEGEN_XML) src/ws/mock-dbus-tests.h
-- $(GDBUS_CODEGEN_INVOCATION)
--
--test_server_SOURCES = \
-- src/ws/mock-service.c \
-- src/ws/mock-service.h \
-- src/ws/test-server.c \
-- $(NULL)
--
--nodist_test_server_SOURCES = \
-- $(GDBUS_CODEGEN_GENERATED) \
-- $(NULL)
--
--test_server_CFLAGS = \
-- -I$(builddir)/src/ws \
-- -I$(top_srcdir)/src/ws \
-- -DG_LOG_DOMAIN=\"test-server\" \
-- $(GIO_CFLAGS) \
-- $(COCKPIT_WS_CFLAGS) \
-- $(NULL)
--
--test_server_LDADD = \
-- $(libcockpit_ws_LIBS) \
-- $(GIO_LIBS) \
-- -lpam \
-- $(NULL)
--
- WS_CHECKS = \
- test-base64 \
- test-creds \
---
-2.11.0
-
diff --git a/meta-webserver/recipes-webadmin/cockpit/files/0002-fix-makefile-use-copy-rule-for-unmodified-files.patch b/meta-webserver/recipes-webadmin/cockpit/files/0002-fix-makefile-use-copy-rule-for-unmodified-files.patch
deleted file mode 100644
index a1ea9bcfdc..0000000000
--- a/meta-webserver/recipes-webadmin/cockpit/files/0002-fix-makefile-use-copy-rule-for-unmodified-files.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 1edf0756bf4fd002f5b60cf2b86d4b97a00aff20 Mon Sep 17 00:00:00 2001
-From: Michael Haener <michael.haener@siemens.com>
-Date: Wed, 25 Mar 2020 08:32:07 +0100
-Subject: [PATCH] fix(makefile): use copy rule for unmodified files
-
----
- pkg/Makefile.am | 27 +++++++++++++++++++++++++++
- 1 file changed, 27 insertions(+)
-
-diff --git a/pkg/Makefile.am b/pkg/Makefile.am
-index 192b785..03b9787 100644
---- a/pkg/Makefile.am
-+++ b/pkg/Makefile.am
-@@ -13,6 +13,33 @@ playground_DATA = \
- dist/playground/extra.de.po: pkg/playground/extra.de.po
- $(COPY_RULE)
-
-+dist/playground/hammer.gif: pkg/playground/hammer.gif
-+ $(COPY_RULE)
-+
-+dist/sosreport/sosreport.png: pkg/sosreport/sosreport.png
-+ $(COPY_RULE)
-+
-+dist/apps/default.png: pkg/apps/default.png
-+ $(COPY_RULE)
-+
-+dist/storaged/images/storage-array.png: pkg/storaged/images/storage-array.png
-+ $(COPY_RULE)
-+
-+dist/storaged/images/storage-disk.png: pkg/storaged/images/storage-disk.png
-+ $(COPY_RULE)
-+
-+dist/shell/images/server-error.png: pkg/shell/images/server-error.png
-+ $(COPY_RULE)
-+
-+dist/shell/images/server-large.png: pkg/shell/images/server-large.png
-+ $(COPY_RULE)
-+
-+dist/shell/images/server-small.png: pkg/shell/images/server-small.png
-+ $(COPY_RULE)
-+
-+dist/shell/index.html: pkg/shell/index.html
-+ $(COPY_RULE)
-+
- metainfodir = ${datarootdir}/metainfo
- metainfo_DATA = pkg/sosreport/org.cockpit-project.cockpit-sosreport.metainfo.xml \
- pkg/kdump/org.cockpit-project.cockpit-kdump.metainfo.xml \
diff --git a/meta-webserver/recipes-webadmin/netdata/netdata/netdata.service b/meta-webserver/recipes-webadmin/netdata/netdata/netdata.service
index b244d18665..f4911f3b6e 100644
--- a/meta-webserver/recipes-webadmin/netdata/netdata/netdata.service
+++ b/meta-webserver/recipes-webadmin/netdata/netdata/netdata.service
@@ -1,13 +1,15 @@
+# SPDX-License-Identifier: GPL-3.0-or-later
[Unit]
-Description=Netdata, Real-time performance monitoring
+Description=Real time performance monitoring
RequiresMountsFor=/var
+After=network.target
[Service]
-User=root
+Type=simple
ExecStartPre=/bin/mkdir -p /var/log/netdata
-ExecStartPre=/bin/chown -R nobody.netdata @@datadir/netdata/web
-ExecStartPre=/bin/chown -R nobody.netdata /var/cache/netdata
-ExecStart=/usr/sbin/netdata -nd
+ExecStartPre=/bin/chown -R netdata:netdata /var/log/netdata
+ExecStart=/usr/sbin/netdata -D -u netdata
+
[Install]
WantedBy=multi-user.target
diff --git a/meta-webserver/recipes-webadmin/netdata/netdata_1.44.3.bb b/meta-webserver/recipes-webadmin/netdata/netdata_1.44.3.bb
new file mode 100644
index 0000000000..700c6b2346
--- /dev/null
+++ b/meta-webserver/recipes-webadmin/netdata/netdata_1.44.3.bb
@@ -0,0 +1,81 @@
+SUMMARY = "Real-time performance monitoring"
+DESCRIPTION = "Netdata is high-fidelity infrastructure monitoring and troubleshooting. \
+ Open-source, free, preconfigured, opinionated, and always real-time."
+HOMEPAGE = "https://github.com/netdata/netdata/"
+LICENSE = "GPL-3.0-only"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fc9b848046ef54b5eaee6071947abd24"
+
+DEPENDS += "json-c libuv libyaml util-linux zlib "
+
+SRC_URI = "\
+ https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BPN}-v${PV}.tar.gz \
+ file://netdata.conf \
+ file://netdata.service \
+"
+
+SRC_URI[sha256sum] = "50df30a9aaf60d550eb8e607230d982827e04194f7df3eba0e83ff7919270ad2"
+
+UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/tags"
+UPSTREAM_CHECK_REGEX = "${BPN}/releases/tag/v(?P<pver>\d+(?:\.\d+)*)"
+
+S = "${WORKDIR}/${BPN}-v${PV}"
+
+# Stop sending anonymous statistics to Google Analytics
+NETDATA_ANONYMOUS ??= "enabled"
+
+inherit pkgconfig autotools-brokensep useradd systemd
+
+LIBS:toolchain-clang:x86 = "-latomic"
+LIBS:riscv64 = "-latomic"
+LIBS:riscv32 = "-latomic"
+LIBS:mips = "-latomic"
+export LIBS
+
+#systemd
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE:${PN} = "netdata.service"
+SYSTEMD_AUTO_ENABLE:${PN} = "enable"
+
+#User specific
+USERADD_PACKAGES = "${PN}"
+USERADD_PARAM:${PN} = "--system --no-create-home --home-dir ${localstatedir}/run/netdata --user-group netdata"
+
+PACKAGECONFIG ??= "openssl"
+PACKAGECONFIG[cloud] = "--enable-cloud, --disable-cloud,"
+PACKAGECONFIG[lz4] = "--enable-lz4, --disable-lz4, lz4"
+PACKAGECONFIG[openssl] = "--enable-openssl, --disable-openssl, openssl"
+
+# ebpf doesn't compile (or detect) the cross compilation well
+EXTRA_OECONF += "--disable-ebpf"
+
+do_install:append() {
+ #set S UID for plugins
+ chmod 4755 ${D}${libexecdir}/netdata/plugins.d/apps.plugin
+
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ # Install systemd unit files
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/netdata.service ${D}${systemd_unitdir}/system
+ sed -i -e 's,@@datadir,${datadir_native},g' ${D}${systemd_unitdir}/system/netdata.service
+ fi
+
+ # Install default netdata.conf
+ install -d ${D}${sysconfdir}/netdata
+ install -m 0644 ${WORKDIR}/netdata.conf ${D}${sysconfdir}/netdata/
+ sed -i -e 's,@@sysconfdir,${sysconfdir},g' ${D}${sysconfdir}/netdata/netdata.conf
+ sed -i -e 's,@@libdir,${libexecdir},g' ${D}${sysconfdir}/netdata/netdata.conf
+ sed -i -e 's,@@datadir,${datadir},g' ${D}${sysconfdir}/netdata/netdata.conf
+
+ if [ "${NETDATA_ANONYMOUS}" = "enabled" ]; then
+ touch ${D}${sysconfdir}/netdata/.opt-out-from-anonymous-statistics
+ fi
+
+ install --group netdata --owner netdata --directory ${D}${localstatedir}/cache/netdata
+ install --group netdata --owner netdata --directory ${D}${localstatedir}/lib/netdata
+
+ chown -R netdata:netdata ${D}${datadir}/netdata/web
+}
+
+FILES:${PN} += "${localstatedir}/cache/netdata/ ${localstatedir}/lib/netdata/"
+
+RDEPENDS:${PN} = "bash python3-core zlib"
diff --git a/meta-webserver/recipes-webadmin/netdata/netdata_git.bb b/meta-webserver/recipes-webadmin/netdata/netdata_git.bb
deleted file mode 100644
index ee4a7c1e3d..0000000000
--- a/meta-webserver/recipes-webadmin/netdata/netdata_git.bb
+++ /dev/null
@@ -1,55 +0,0 @@
-HOMEPAGE = "https://github.com/firehol/netdata/"
-SUMMARY = "Real-time performance monitoring"
-LICENSE = "GPLv3"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=fc9b848046ef54b5eaee6071947abd24"
-
-SRC_URI = "git://github.com/firehol/netdata.git;protocol=https"
-SRCREV = "1be9200ba8e11dc81a2101d85a2725137d43f766"
-PV = "1.22.1"
-
-# default netdata.conf for netdata configuration
-SRC_URI += "file://netdata.conf"
-
-# file for providing systemd service support
-SRC_URI += "file://netdata.service"
-
-S = "${WORKDIR}/git"
-
-DEPENDS += "zlib util-linux libuv"
-
-inherit pkgconfig autotools-brokensep useradd systemd
-
-LIBS_toolchain-clang_x86 = "-latomic"
-LIBS_riscv64 = "-latomic"
-LIBS_riscv32 = "-latomic"
-export LIBS
-
-#systemd
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "netdata.service"
-SYSTEMD_AUTO_ENABLE_${PN} = "enable"
-
-#User specific
-USERADD_PACKAGES = "${PN}"
-GROUPADD_PARAM_${PN} = "--system netdata"
-
-do_install_append() {
- #set S UID for plugins
- chmod 4755 ${D}${libexecdir}/netdata/plugins.d/apps.plugin
-
- if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
- # Install systemd unit files
- install -d ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/netdata.service ${D}${systemd_unitdir}/system
- sed -i -e 's,@@datadir,${datadir_native},g' ${D}${systemd_unitdir}/system/netdata.service
- fi
-
- # Install default netdata.conf
- install -d ${D}${sysconfdir}/netdata
- install -m 0644 ${WORKDIR}/netdata.conf ${D}${sysconfdir}/netdata/
- sed -i -e 's,@@sysconfdir,${sysconfdir},g' ${D}${sysconfdir}/netdata/netdata.conf
- sed -i -e 's,@@libdir,${libexecdir},g' ${D}${sysconfdir}/netdata/netdata.conf
- sed -i -e 's,@@datadir,${datadir},g' ${D}${sysconfdir}/netdata/netdata.conf
-}
-
-RDEPENDS_${PN} = "bash zlib"
diff --git a/meta-webserver/recipes-webadmin/webmin/files/disable-version-check.patch b/meta-webserver/recipes-webadmin/webmin/files/disable-version-check.patch
index 9aad894e0c..1ca26ca0dd 100644
--- a/meta-webserver/recipes-webadmin/webmin/files/disable-version-check.patch
+++ b/meta-webserver/recipes-webadmin/webmin/files/disable-version-check.patch
@@ -3,7 +3,7 @@ Disable OS version check in status screen
The code is not able to accurately detect the correct distro/version at
the moment.
-Upstream-status: Inappropriate
+Upstream-Status: Inappropriate
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
diff --git a/meta-webserver/recipes-webadmin/webmin/files/init-exclude.patch b/meta-webserver/recipes-webadmin/webmin/files/init-exclude.patch
index 4212917f6e..489318b4bd 100644
--- a/meta-webserver/recipes-webadmin/webmin/files/init-exclude.patch
+++ b/meta-webserver/recipes-webadmin/webmin/files/init-exclude.patch
@@ -1,11 +1,11 @@
-# Hack in support for an "exclude" config option for the init module, so
-# we can hide certain system services that shouldn't really be configurable
-# via the web interface
-#
-# Upstream-status: Pending
-#
-# Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
-# Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
+Hack in support for an "exclude" config option for the init module, so
+we can hide certain system services that shouldn't really be configurable
+via the web interface
+
+Upstream-Status: Pending
+
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
---
init/index.cgi | 27 ++++++++++++++-------------
init/init-lib.pl | 5 +++--
diff --git a/meta-webserver/recipes-webadmin/webmin/files/media-tomb.patch b/meta-webserver/recipes-webadmin/webmin/files/media-tomb.patch
index 46f3109796..dfc962bfb7 100644
--- a/meta-webserver/recipes-webadmin/webmin/files/media-tomb.patch
+++ b/meta-webserver/recipes-webadmin/webmin/files/media-tomb.patch
@@ -1,3 +1,7 @@
+add mediatomb support
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
diff -Nru webmin-1.570.bak/mediatomb/index.cgi webmin-1.570/mediatomb/index.cgi
--- webmin-1.570.bak/mediatomb/index.cgi 1969-12-31 16:00:00.000000000 -0800
+++ webmin-1.570/mediatomb/index.cgi 2011-10-26 10:00:05.992522036 -0700
diff --git a/meta-webserver/recipes-webadmin/webmin/files/mount-excludefs.patch b/meta-webserver/recipes-webadmin/webmin/files/mount-excludefs.patch
index 8cb74c4b13..787bd8c69b 100644
--- a/meta-webserver/recipes-webadmin/webmin/files/mount-excludefs.patch
+++ b/meta-webserver/recipes-webadmin/webmin/files/mount-excludefs.patch
@@ -6,7 +6,7 @@ since these shouldn't be modified from the web interface.
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
-Upstream-status: Pending
+Upstream-Status: Pending
--- webmin-1.570.orig/mount/index.cgi
+++ webmin-1.570/mount/index.cgi
diff --git a/meta-webserver/recipes-webadmin/webmin/files/mysql-config-fix.patch b/meta-webserver/recipes-webadmin/webmin/files/mysql-config-fix.patch
index 2cbc627076..c6c1f0df79 100644
--- a/meta-webserver/recipes-webadmin/webmin/files/mysql-config-fix.patch
+++ b/meta-webserver/recipes-webadmin/webmin/files/mysql-config-fix.patch
@@ -3,7 +3,7 @@ From: Diego Rondini <diego.ml@zoho.com>
Date: Thu, 18 Feb 2016 15:44:06 +0100
Subject: [PATCH] Adjust Mysql config defaults
-Upstream-status: Inappropriate [configuration]
+Upstream-Status: Inappropriate [configuration]
Signed-off-by: Diego Rondini <diego.ml@zoho.com>
---
diff --git a/meta-webserver/recipes-webadmin/webmin/files/net-generic.patch b/meta-webserver/recipes-webadmin/webmin/files/net-generic.patch
index 5549392851..6ae3dced72 100644
--- a/meta-webserver/recipes-webadmin/webmin/files/net-generic.patch
+++ b/meta-webserver/recipes-webadmin/webmin/files/net-generic.patch
@@ -1,8 +1,8 @@
-# Add support for configuring network interfaces on a generic linux system
-#
-# Upstream-status: Not appropriate [config]
-#
-# Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+Add support for configuring network interfaces on a generic linux system
+
+Upstream-Status: Inappropriate [config]
+
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Index: webmin-1.850/net/module.info
===================================================================
--- webmin-1.850.orig/net/module.info
diff --git a/meta-webserver/recipes-webadmin/webmin/files/proftpd-config-fix.patch b/meta-webserver/recipes-webadmin/webmin/files/proftpd-config-fix.patch
index 492a652d48..4e78ff4c22 100644
--- a/meta-webserver/recipes-webadmin/webmin/files/proftpd-config-fix.patch
+++ b/meta-webserver/recipes-webadmin/webmin/files/proftpd-config-fix.patch
@@ -1,4 +1,4 @@
-Upstream-status: Inappropriate [configuration]
+Upstream-Status: Inappropriate [configuration]
Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
diff --git a/meta-webserver/recipes-webadmin/webmin/files/remove-startup-option.patch b/meta-webserver/recipes-webadmin/webmin/files/remove-startup-option.patch
index d957f4a3bc..358e53ab8c 100644
--- a/meta-webserver/recipes-webadmin/webmin/files/remove-startup-option.patch
+++ b/meta-webserver/recipes-webadmin/webmin/files/remove-startup-option.patch
@@ -1,9 +1,9 @@
-# Remove "start on boot" option from webmin configuration, as
-# end-users should not need to configure this from the web interface
-#
-# Upstream-status: Inappropriate
-#
-# Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+Remove "start on boot" option from webmin configuration, as
+end-users should not need to configure this from the web interface
+
+Upstream-Status: Inappropriate [OE-specific]
+
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
--- webmin-1.570.orig/webmin/index.cgi
+++ webmin-1.570/webmin/index.cgi
@@ -79,20 +79,6 @@ print &ui_buttons_start();
diff --git a/meta-webserver/recipes-webadmin/webmin/files/samba-config-fix.patch b/meta-webserver/recipes-webadmin/webmin/files/samba-config-fix.patch
index 46645ac30e..d9ea2d145e 100644
--- a/meta-webserver/recipes-webadmin/webmin/files/samba-config-fix.patch
+++ b/meta-webserver/recipes-webadmin/webmin/files/samba-config-fix.patch
@@ -1,4 +1,4 @@
-Upstream-status: Inappropriate [configuration]
+Upstream-Status: Inappropriate [configuration]
Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
diff --git a/meta-webserver/recipes-webadmin/webmin/webmin_1.850.bb b/meta-webserver/recipes-webadmin/webmin/webmin_1.850.bb
index 112365d4be..35ec09daea 100644
--- a/meta-webserver/recipes-webadmin/webmin/webmin_1.850.bb
+++ b/meta-webserver/recipes-webadmin/webmin/webmin_1.850.bb
@@ -126,26 +126,26 @@ do_install() {
INITSCRIPT_NAME = "webmin"
INITSCRIPT_PARAMS = "start 99 5 3 2 . stop 10 0 1 6 ."
-SYSTEMD_SERVICE_${PN} = "webmin.service"
-SYSTEMD_AUTO_ENABLE_${PN} = "disable"
+SYSTEMD_SERVICE:${PN} = "webmin.service"
+SYSTEMD_AUTO_ENABLE:${PN} = "disable"
# FIXME: some of this should be figured out automatically
-RDEPENDS_${PN} += "perl perl-module-socket perl-module-exporter perl-module-exporter-heavy perl-module-carp perl-module-strict"
-RDEPENDS_${PN} += "perl-module-warnings perl-module-xsloader perl-module-posix perl-module-autoloader"
-RDEPENDS_${PN} += "perl-module-fcntl perl-module-tie-hash perl-module-vars perl-module-time-local perl-module-config perl-module-constant"
-RDEPENDS_${PN} += "perl-module-file-glob perl-module-file-copy perl-module-sdbm-file perl-module-feature"
+RDEPENDS:${PN} += "perl perl-module-socket perl-module-exporter perl-module-exporter-heavy perl-module-carp perl-module-strict"
+RDEPENDS:${PN} += "perl-module-warnings perl-module-xsloader perl-module-posix perl-module-autoloader"
+RDEPENDS:${PN} += "perl-module-fcntl perl-module-tie-hash perl-module-vars perl-module-time-local perl-module-config perl-module-constant"
+RDEPENDS:${PN} += "perl-module-file-glob perl-module-file-copy perl-module-sdbm-file perl-module-feature"
PACKAGES_DYNAMIC += "webmin-module-* webmin-theme-*"
-RRECOMMENDS_${PN} += "webmin-module-system-status"
+RRECOMMENDS:${PN} += "webmin-module-system-status"
PACKAGES += "${PN}-module-proc ${PN}-module-raid ${PN}-module-exports ${PN}-module-fdisk ${PN}-module-lvm"
-RDEPENDS_${PN}-module-proc = "procps"
-RDEPENDS_${PN}-module-raid = "mdadm"
-RDEPENDS_${PN}-module-exports = "perl-module-file-basename perl-module-file-path perl-module-cwd perl-module-file-spec perl-module-file-spec-unix"
-RRECOMMENDS_${PN}-module-fdisk = "parted"
-RRECOMMENDS_${PN}-module-lvm = "lvm2"
+RDEPENDS:${PN}-module-proc = "procps"
+RDEPENDS:${PN}-module-raid = "mdadm"
+RDEPENDS:${PN}-module-exports = "perl-module-file-basename perl-module-file-path perl-module-cwd perl-module-file-spec perl-module-file-spec-unix"
+RRECOMMENDS:${PN}-module-fdisk = "parted"
+RRECOMMENDS:${PN}-module-lvm = "lvm2"
-python populate_packages_prepend() {
+python populate_packages:prepend() {
import os, os.path
wadir = bb.data.expand('${libexecdir}/webmin', d)