aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-apps/menulibre/menulibre_2.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-apps/menulibre/menulibre_2.3.2.bb')
-rw-r--r--meta-xfce/recipes-apps/menulibre/menulibre_2.3.2.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-xfce/recipes-apps/menulibre/menulibre_2.3.2.bb b/meta-xfce/recipes-apps/menulibre/menulibre_2.3.2.bb
new file mode 100644
index 0000000000..7491b509cc
--- /dev/null
+++ b/meta-xfce/recipes-apps/menulibre/menulibre_2.3.2.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "An advanced menu editor"
+HOMEPAGE = "https://bluesabre.org/menulibre/"
+SECTION = "x11/graphics"
+LICENSE = "GPL-3.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+DEPENDS = " \
+ python3-distutils-extra-native \
+ intltool-native \
+"
+
+inherit setuptools3_legacy gtk-icon-cache features_check
+REQUIRED_DISTRO_FEATURES = "x11 gobject-introspection-data"
+
+SRC_URI = "git://github.com/bluesabre/menulibre.git;protocol=https;branch=master"
+SRCREV = "94bef4060714fa65c7246c25b87410b52a149f94"
+S = "${WORKDIR}/git"
+
+do_compile[noexec] = "1"
+
+do_install:append() {
+ sed -i 's:${D}::g' ${D}${datadir}/applications/menulibre.desktop
+ sed -i 's:share/share:share:g' ${D}${PYTHON_SITEPACKAGES_DIR}/menulibre_lib/menulibreconfig.py
+}
+
+FILES:${PN} += " \
+ ${datadir}/applications \
+ ${datadir}/metainfo \
+ ${datadir}/icons \
+"
+
+RDEPENDS:${PN} += " \
+ gtk+3 \
+ gtksourceview3 \
+ python3-pygobject \
+ gnome-menus \
+ python3-unixadmin \
+ python3-psutil \
+"