aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce
Commit message (Collapse)AuthorAgeFilesLines
* xfce4-vala: unbreak by telling configure new vala API versionMartin Jansa2016-07-291-1/+1
| | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-terminal: add dependency on vte9-termcapDmitry Rozhkov2016-07-291-0/+1
| | | | | | | | | | xfce4-terminal requires vte9-termcap to be installed at run time to be fully functional. The patch adds vte9-termcap to xfce4-terminal's RDEPENDS. Signed-off-by: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* mousepad: remove blacklist caused by gtksourceview2Yi Zhao2016-07-291-1/+0
| | | | | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libxfce4ui: Use native intltool for building the libDmitry Rozhkov2016-07-291-1/+1
| | | | | | | | Otherwise the dependency on intltool-dev is icluded mistakenly to RRECOMMENDS of the libxfce4ui-dev package. Signed-off-by: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gnome-terminal, toscoterm, vala-terminal, xfce4-terminal: use vte9Jussi Kukkonen2016-06-231-1/+1
| | | | | | | | | geany-plugins seems to compile fine with new vte: that recipe was not modified. gnome-terminal and vala-terminal are currently blacklisted for other reasons. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* epdf, evince, tracker, gimp, tumbler: Remove blacklist caused by poppler ↵Derek Straka2016-06-231-2/+0
| | | | | | | build failures Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* evince, epdf, gdm, gnumeric, libgnomeprint, tumbler, gedit, gnome-panel, ↵Martin Jansa2016-06-133-1/+6
| | | | | | gnome-session, gnome-terminal, libgnomecups, gtksourceview2, libgweather, libgnomeui, tracker, gimp, poppler, mousepad, goffice, tasks: blacklist, fails to build with gcc-6 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-eyes-plugin: update to 4.4.5Andreas Müller2016-05-061-2/+2
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-cpufreq-plugin: update to 1.1.3Andreas Müller2016-05-061-2/+2
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce-polkit: fix warning not able to copy licenseAndreas Müller2016-05-061-1/+1
| | | | | | | | | COPYING is a link on LICENSE. It seems that cause the warning so use LICENSE. Fixes: | WARNING: xfce-polkit-0.2-r0 do_populate_lic: Could not copy license file /home/superandy/tmp/oe-core-glibc/work/cortexa7t2hf-neon-vfpv4-angstrom-linux-gnueabi/xfce-polkit/0.2-r0/git/COPYING to /home/superandy/tmp/oe-core-glibc/work/cortexa7t2hf-neon-vfpv4-angstrom-linux-gnueabi/xfce-polkit/0.2-r0/license-destdir/xfce-polkit/COPYING: [Errno 2] No such file or directory: '/home/superandy/tmp/oe-core-glibc/work/cortexa7t2hf-neon-vfpv4-angstrom-linux-gnueabi/xfce-polkit/0.2-r0/license-destdir/xfce-polkit/COPYING' Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* meta-xfce: add intltool-native to DEPENDSAndreas Müller2016-05-065-4/+6
| | | | | | | | | fix tons of messages as: | WARNING: foo do_configure: Missing DEPENDS on intltool-native Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-weather-plugin: update to 0.8.7Andreas Müller2016-04-281-2/+2
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-whiskermenu-plugin: update to 1.5.3Andreas Müller2016-04-281-2/+2
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* meta-xfce: use bb.utils.contains() instead of base_contains()Ross Burton2016-04-282-6/+6
| | | | | | | | base_contains() is a compatibility wrapper and may warn in the future, so replace all instances with bb.utils.contains(). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-clipman-plugin: Add PACKAGECONFIG for qrencodeMartin Jansa2016-03-251-0/+1
| | | | | | | * fixes: WARN: xfce4-clipman-plugin: xfce4-clipman-plugin rdepends on qrencode, but it isn't a build dependency? Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* packagegroup-xfce-extended: add xfce4-verve-pluginAndreas Müller2016-03-251-0/+1
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-verve-plugin: initial add 1.1.0Andreas Müller2016-03-251-0/+9
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-pulseaudio-plugin: update to 0.2.4Andreas Müller2016-03-251-2/+2
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* parole: update to 0.8.1Andreas Müller2016-03-252-33/+2
| | | | | | | checked: patch or similar (for appdata) was applied Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-vala: unbreak by telling configure new vala API versionMartin Jansa2016-02-251-1/+1
| | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-xkb-plugin: update to 0.7.1Andreas Müller2016-02-251-2/+2
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-panel: make date/time plugins handle timezone changes properlyAndreas Müller2016-02-253-0/+652
| | | | | | | 0001... was applied to make 0002... apply on 4.12-release and git master branch. Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-whiskermenu-plugin: update to 1.5.2Andreas Müller2016-02-251-3/+2
| | | | | | | sources moved to common xfce panel location Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* packagegroup-xfce-extended: add xfce4-calculator-pluginAndreas Müller2016-02-151-0/+1
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-calculator-plugin: initial add 0.5.1Andreas Müller2016-02-151-0/+9
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* thunar: remove udisks from RRECOMMENDSAndreas Müller2016-01-271-1/+1
| | | | | | | now gvfs takes care to include all we need for automounting / network browsing Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-power-manager: remove udisks rdependencyAndreas Müller2016-01-271-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | udisks spin down feature support was removed in: commit dc6ef998a2f19b6c2fcbfb48164db04be44c885d Author: Harald Judt <h.judt@gmx.at> Date: Sun Jul 13 21:34:22 2014 +0200 Remove disk spin down feature (3/3) Finally, let's remove the low-level code and remaining definitions. commit c9d0626110e4b6e906610e9a2316cdac7a11d58e Author: Harald Judt <h.judt@gmx.at> Date: Sun Jul 13 21:26:21 2014 +0200 Remove disk spin down feature (2/3) Remove all related GUI widgets from the settings dialog. commit 3ad75fad293fb66e6316aa5820ee064f264eafa4 Author: Harald Judt <h.judt@gmx.at> Date: Sun Jul 13 21:22:05 2014 +0200 Remove disk spin down feature (1/3) The spin down feature does not work and would need a rewrite to work with udisks-2. What's more, it is probably functionality best handled by other tools or scripts, so let's remove it from the power manager. As a first step, this commit removes all interfacing code between GUI and low-level udisks functions. Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* packagegroup-xfce-extended: add xfce4-sensors-pluginAndreas Müller2016-01-061-0/+1
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-sensors-plugin: initial add 1.2.6Andreas Müller2016-01-061-0/+27
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* imsettings: Move from meta-ruby to meta-xfceKhem Raj2015-12-183-0/+69
| | | | | | | | | | | | | | | | It depends on xfconf which is XFCE component, no one depends on imsettings in meta-ruby so move it close to its dependencies. Ideally, xfconf should be turned into PACKAGECONFIG and this recipe then moved to meta-oe since all kind of DE's can use it then. For now it frees meta-ruby from unnecessary dependency on xfce layer Change-Id: I6b5896b0db504fad49a9da5967d3493e27c627b0 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-session: exclude machine-host dependency with ↵Martin Jansa2015-11-161-0/+4
| | | | | | | | | | | | | | | | | | | | SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS * this whole machine-host is very bad idea, all changes from postinst will be removed when netbase package is upgraded (it has CONFFILES set but most users won't know that this entry was appended by machine-host package) * see: http://lists.openembedded.org/pipermail/openembedded-devel/2015-September/103271.html * fixes: ERROR: xfce4-session different signature for task do_package_write_ipk.sigdata between qemux86copy and qemux86 runtaskdeps changed from ['dbusdbus_1.8.20.bb.do_packagedata', 'opkg-utilsopkg-utils_git.bb.do_populate_sysroot:virtual:native', 'pseudopseudo_1.7.4.bb.do_populate_sysroot:virtual:native', 'upowerupower_0.9.14.bb.do_packagedata', 'xfce4-sessionmachine-host.bb.do_packagedata', 'xfce4-sessionxfce4-session_4.12.1.bb.do_package', 'xfce4-sessionxfce4-session_4.12.1.bb.do_packagedata', 'xorg-appiceauth_1.0.7.bb.do_packagedata', 'xorg-appxinit_1.3.4.bb.do_packagedata'] to ['dbusdbus_1.8.20.bb.do_packagedata', 'opkg-utilsopkg-utils_git.bb.do_populate_sysroot:virtual:native', 'pseudopseudo_1.7.4.bb.do_populate_sysroot:virtual:native', 'upowerupower_0.9.14.bb.do_packagedata', 'xfce4-sessionmachine-host.bb.do_packagedata', 'xfce4-sessionxfce4-session_4.12.1.bb.do_package', 'xfce4-sessionxfce4-session_4.12.1.bb.do_packagedata', 'xorg-appiceauth_1.0.7.bb.do_packagedata', 'xorg-appxinit_1.3.4.bb.do_packagedata'] meta-openembedded/meta-xfce/recipes-xfce/xfce4-session/machine-host.bb.do_packagedata with hash 7b3f9a883729dfe908e17980476d10e2 changed to meta-openembedded/meta-xfce/recipes-xfce/xfce4-session/machine-host.bb.do_packagedata with hash f51309cb641c82a6d8e2dc5387bb6484 Hash for dependent task xfce4-sessionmachine-host.bb.do_packagedata changed from 7b3f9a883729dfe908e17980476d10e2 to f51309cb641c82a6d8e2dc5387bb6484 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* mousepad: inherit gsettingsKai Kang2015-11-061-1/+1
| | | | | | | | | | | | When launch mousepad, it fails with: | glib-gio-error setting schema 'org.xfce.mousepad' is not installed It needs to call glib-compile-schemas to compile its schema file. Inherit gsettings to fix it. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-whiskermenu-plugin: update to 1.5.1Andreas Müller2015-11-061-7/+3
| | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
* packagegroup-xfce-extended: xfce-polkitAndreas Müller2015-11-061-0/+2
| | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
* xfce-polkit: initial add 0.2Andreas Müller2015-11-061-0/+11
| | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
* xfce4-vala: unbreak by telling configure vala API versionAndreas Müller2015-11-061-2/+2
| | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
* xfce4-battery-plugin: fix build on arm64Kai Kang2015-10-232-0/+36
| | | | | | | Backport patch to fix build on arm64. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* vim: do not autoenable the mouseJackie Huang2015-10-231-0/+6
| | | | | | | | | The mouse being autoenabled is just annoying in xfce4-terminal (mouse drag make vim go into visual mode and there is no right click menu), so remove the setting for xfce. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-screenshooter: ensure output directory is createdJackie Huang2015-10-132-0/+31
| | | | | | | | | | | | When build with B != S, the output directory for desktop file doesn't exist so it will fail if it's not created before generating the file: /bin/sh: line 1: src/xfce4-screenshooter.desktop.in: No such file or directory Add "$(MKDIR_P) $(dir $@)" to the rule to fix this. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-pulseaudio-plugin: add packageconfig for libnotifyJackie Huang2015-09-231-0/+3
| | | | | | | | | | Add PACKAGECONFIG for libnotify and disable it by default to avoid the QA issue: WARNING: QA Issue: xfce4-pulseaudio-plugin rdepends on libnotify, but it isn't a build dependency? [build-deps] Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-settings: make Adwaita default icon themeAndreas Müller2015-09-231-1/+1
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-settings: get 0001-xsettings.xml-Set-default-themes.patch backAndreas Müller2015-09-232-2/+38
| | | | | | | | This patch was accidently included in the git source branch. It is neither new functionality nor bugfix. It is a configuration and should remain in meta-xfce. Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-settings: remove libnotify from DEPENDS - it is in PACKAGECONFIGAndreas Müller2015-09-231-1/+1
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-power-manager: make upower a build dependencyAndreas Müller2015-09-231-2/+2
| | | | | | | | | | | | | | | | This one came up when upower failed: | *** The required package upower-glib was not found on your system. | *** Please install upower-glib (atleast version 0.9.7) or adjust | *** the PKG_CONFIG_PATH environment variable if you | *** installed the package in a nonstandard prefix so that | *** pkg-config is able to find it. xfce4-power-manager links against upower so we can expect shlibs causing upower being added to RDEPENDS. Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* thunar-volman: replace udev by libgudev in DEPENDSAndreas Müller2015-09-231-1/+1
| | | | | | | | | | fixes: | checking for gudev-1.0 >= 145... not found | *** The required package gudev-1.0 was not found on your system. | *** Please install gudev-1.0 (atleast version 145) or adjust Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* xfce4-settings: recommend adwaita, not gnome-icon-themeJussi Kukkonen2015-09-231-1/+1
| | | | | | | | RRECOMMEND adwaita-icon-theme instead of gnome-icon-theme (as latter is removed from oe-core). Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libxfce4ui: add RDEPENDS on PN for PN-gtk2 and PN-gtk3Jackie Huang2015-09-231-0/+3
| | | | | | | | | | | | | | gtk libs was separated into PN-gtk after commit: d4e5b33 libxfce4ui: build gtk3 libs and pack gtk2/gtk3 libs in separate packages but config files such as xfce4-keyboard-shortcuts.xml is in PN, it works without this, but there no any keyboard shortcut, add the RDEPENDS so that the libs and config files will be both installed. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Acked-By: Andreas Müller <schnitzeltony@goolglemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* meta-xfce/README: mention meta-gnome in layers requiredAndreas Müller2015-09-231-1/+1
| | | | | | | | form a quick glance meta-xfce at least requires libwnck and gvfs to build an run properly. Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* packagegroup-xfce-multimedia: add paroleAndreas Müller2015-09-231-0/+1
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* parole: initial add 0.8.0Andreas Müller2015-09-232-0/+67
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>