aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/images
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-08-02 19:38:14 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-08-02 19:38:14 +0100
commit551074e932562078fb1fb4cf606b2a3baa1bbb70 (patch)
treeefb996551db0acdf2fc94f9cb8eb04d179b607b7 /recipes-opie/images
parent60f86212e16ba8f80ed930f8c65d7dc9c3c550cd (diff)
downloadmeta-opie-551074e932562078fb1fb4cf606b2a3baa1bbb70.tar.gz
Fix /etc/timestamp creation for Opie images
Use the OE-core style for creation of /etc/timestamp. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/images')
-rw-r--r--recipes-opie/images/jlime-opie.bb5
-rw-r--r--recipes-opie/images/opie-image-16mb.bb7
-rw-r--r--recipes-opie/images/opie-image.bb7
3 files changed, 11 insertions, 8 deletions
diff --git a/recipes-opie/images/jlime-opie.bb b/recipes-opie/images/jlime-opie.bb
index bb9ad73..816e8f9 100644
--- a/recipes-opie/images/jlime-opie.bb
+++ b/recipes-opie/images/jlime-opie.bb
@@ -56,7 +56,8 @@ merge_feeds() {
fi
}
+inherit image
+
# merge feed-sources into ipkg.conf and create /etc/timestamp from build date
-IMAGE_PREPROCESS_COMMAND = "merge_feeds; create_etc_timestamp"
+ROOTFS_POSTPROCESS_COMMAND += "merge_feeds; rootfs_update_timestamp ; "
-inherit image
diff --git a/recipes-opie/images/opie-image-16mb.bb b/recipes-opie/images/opie-image-16mb.bb
index 8f706aa..253c005 100644
--- a/recipes-opie/images/opie-image-16mb.bb
+++ b/recipes-opie/images/opie-image-16mb.bb
@@ -15,7 +15,8 @@ IMAGE_INSTALL = "task-boot \
task-opie-16mb-pim \
${ANGSTROM_EXTRA_INSTALL} "
-# create /etc/timestamp from build date
-IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
-
inherit image
+
+# Create /etc/timestamp during image construction to give a reasonably sane default time setting
+ROOTFS_POSTPROCESS_COMMAND += "rootfs_update_timestamp ; "
+
diff --git a/recipes-opie/images/opie-image.bb b/recipes-opie/images/opie-image.bb
index 67ace80..f7f3e21 100644
--- a/recipes-opie/images/opie-image.bb
+++ b/recipes-opie/images/opie-image.bb
@@ -14,7 +14,8 @@ IMAGE_INSTALL = "task-base-extended task-opie-base task-opie-base-applets \
${@base_contains("COMBINED_FEATURES", "irda", "task-opie-irda", "",d)} \
${ANGSTROM_EXTRA_INSTALL} "
-# create /etc/timestamp from build date
-IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
-
inherit image
+
+# Create /etc/timestamp during image construction to give a reasonably sane default time setting
+ROOTFS_POSTPROCESS_COMMAND += "rootfs_update_timestamp ; "
+