aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/meta
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/meta
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/meta')
-rw-r--r--recipes-opie/meta/meta-opie-all.bb16
-rw-r--r--recipes-opie/meta/meta-opie.bb20
-rw-r--r--recipes-opie/meta/meta-toolchain-opie.bb8
3 files changed, 44 insertions, 0 deletions
diff --git a/recipes-opie/meta/meta-opie-all.bb b/recipes-opie/meta/meta-opie-all.bb
new file mode 100644
index 0000000..e6a0da7
--- /dev/null
+++ b/recipes-opie/meta/meta-opie-all.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Meta-package for QPE stuff"
+SECTION = "opie/base"
+LICENSE = "MIT"
+PR = "r4"
+
+RDEPENDS_${PN} = " \
+ task-qpe-applets \
+ task-qpe-games \
+ task-qpe-inputmethods \
+ task-qpe-multimedia \
+ task-qpe-emulators \
+ task-qpe-applications \
+ task-qpe-fonts \
+ task-qpe-settings"
+
+inherit meta
diff --git a/recipes-opie/meta/meta-opie.bb b/recipes-opie/meta/meta-opie.bb
new file mode 100644
index 0000000..1584765
--- /dev/null
+++ b/recipes-opie/meta/meta-opie.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Meta-package for Opie"
+SECTION = "opie/base"
+PR = "r35"
+LICENSE = "MIT"
+
+RDEPENDS_${PN} = "task-opie-applets task-opie-apps task-opie-base \
+ task-opie-base-applets task-opie-base-apps \
+ task-opie-base-decorations task-opie-base-inputmethods \
+ task-opie-base-pim task-opie-base-settings \
+ task-opie-base-styles \
+ ${@base_contains("COMBINED_FEATURES", "bluetooth", "task-opie-bluetooth", "",d)} \
+ task-opie-datebookplugins task-opie-decorations \
+ task-opie-extra-apps task-opie-extra-settings \
+ task-opie-extra-styles task-opie-extra-games \
+ ${@base_contains("COMBINED_FEATURES", "irda", "task-opie-irda", "",d)} \
+ task-opie-games task-opie-inputmethods \
+ task-opie-multimedia task-opie-pim task-opie-settings \
+ task-opie-styles task-opie-todayplugins task-opie-wlan"
+
+inherit meta
diff --git a/recipes-opie/meta/meta-toolchain-opie.bb b/recipes-opie/meta/meta-toolchain-opie.bb
new file mode 100644
index 0000000..9f4b9ac
--- /dev/null
+++ b/recipes-opie/meta/meta-toolchain-opie.bb
@@ -0,0 +1,8 @@
+PR = "r1"
+TOOLCHAIN_TARGET_TASK = "\
+ task-sdk-base \
+ task-sdk-opie"
+
+require meta-toolchain.bb
+
+SDK_SUFFIX = "toolchain-opie"