aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-examples-python
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/opie-examples-python
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/opie-examples-python')
-rw-r--r--recipes-opie/opie-examples-python/opie-examples-python.inc27
-rw-r--r--recipes-opie/opie-examples-python/opie-examples-python_1.2.5.bb11
-rw-r--r--recipes-opie/opie-examples-python/opie-examples-python_cvs.bb7
3 files changed, 45 insertions, 0 deletions
diff --git a/recipes-opie/opie-examples-python/opie-examples-python.inc b/recipes-opie/opie-examples-python/opie-examples-python.inc
new file mode 100644
index 0000000..3a784a3
--- /dev/null
+++ b/recipes-opie/opie-examples-python/opie-examples-python.inc
@@ -0,0 +1,27 @@
+DESCRIPTION = "Python examples for Opie"
+SECTION = "opie/base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS_${PN} = "python-pyqt opie-pyquicklaunchapplet"
+APPNAME = "python"
+PACKAGE_ARCH = "all"
+
+S = "${WORKDIR}/${APPNAME}"
+
+inherit opie
+
+do_configure() {
+ :
+}
+
+do_compile() {
+ :
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin/python/ ${D}${palmtopdir}/apps/Python
+ install -m 0755 *.py ${D}${palmtopdir}/bin/python/
+ install -m 0644 ${WORKDIR}/apps/Python/.directory ${D}${palmtopdir}/apps/Python/
+ install -m 0644 ${WORKDIR}/apps/Python/simple.desktop ${D}${palmtopdir}/apps/Python/
+}
+
diff --git a/recipes-opie/opie-examples-python/opie-examples-python_1.2.5.bb b/recipes-opie/opie-examples-python/opie-examples-python_1.2.5.bb
new file mode 100644
index 0000000..02426f0
--- /dev/null
+++ b/recipes-opie/opie-examples-python/opie-examples-python_1.2.5.bb
@@ -0,0 +1,11 @@
+require ${PN}.inc
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_examples_python.tar.bz2;name=split_examples_python \
+ http://sources.openembedded.org/opie-1.2.5-split_pics.tar.bz2;name=split_pics \
+ http://sources.openembedded.org/opie-1.2.5-split_apps.tar.bz2;name=split_apps"
+SRC_URI[split_examples_python.md5sum] = "19cc8165731d2500be06ea628be37d5c"
+SRC_URI[split_examples_python.sha256sum] = "9f82baf3a3d251e352edecc9efa29501cb98cad7cff9fd2aab192b8c6d04aa3d"
+SRC_URI[split_pics.md5sum] = "e9b68749d67295f7080a23e39b17335e"
+SRC_URI[split_pics.sha256sum] = "0a7aab6d0bce04d6a9c257d768d8a1a481d38ba527d6e6e50723973789954b4a"
+SRC_URI[split_apps.md5sum] = "c765d13427e4dc8ee396e4dfed2dbe73"
+SRC_URI[split_apps.sha256sum] = "0fea454d8d286f7febc7449e4a06f73e941e8b22e9bab904a32e57f35479862a"
diff --git a/recipes-opie/opie-examples-python/opie-examples-python_cvs.bb b/recipes-opie/opie-examples-python/opie-examples-python_cvs.bb
new file mode 100644
index 0000000..330e09d
--- /dev/null
+++ b/recipes-opie/opie-examples-python/opie-examples-python_cvs.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=examples/python \
+ ${OPIE_GIT};protocol=git;subpath=pics \
+ ${OPIE_GIT};protocol=git;subpath=apps"