aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-help-en
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/opie-help-en
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/opie-help-en')
-rw-r--r--recipes-opie/opie-help-en/opie-help-en.inc27
-rw-r--r--recipes-opie/opie-help-en/opie-help-en_1.2.5.bb7
-rw-r--r--recipes-opie/opie-help-en/opie-help-en_cvs.bb7
3 files changed, 41 insertions, 0 deletions
diff --git a/recipes-opie/opie-help-en/opie-help-en.inc b/recipes-opie/opie-help-en/opie-help-en.inc
new file mode 100644
index 0000000..1b110f9
--- /dev/null
+++ b/recipes-opie/opie-help-en/opie-help-en.inc
@@ -0,0 +1,27 @@
+DESCRIPTION = "Opie Help Packages - English"
+SECTION = "opie/help"
+PRIORITY = "optional"
+LICENSE = "GPL"
+ALLOW_EMPTY = "1"
+PACKAGE_ARCH = "all"
+
+PACKAGES += "${PN}"
+RDEPENDS_${PN} = "opie-helpbrowser"
+
+S = "${WORKDIR}/html"
+
+do_install() {
+ install -d ${D}${palmtopdir}/help/en/html/
+ install -m 0644 ${WORKDIR}/html/*.html ${D}${palmtopdir}/help/en/html/
+ for d in $(find . -type d | grep -v "CVS\|patch")
+ do
+ install -d ${D}${palmtopdir}/help/en/html/$d
+ install -m 0644 ${WORKDIR}/html/$d/*.html ${D}${palmtopdir}/help/en/html/$d/
+ done
+}
+
+python populate_packages_prepend () {
+ help_dir = bb.data.expand('${palmtopdir}/help/en/html/', d)
+
+ do_split_packages(d, help_dir, file_regex='^(.*)\.html$', output_pattern='opie-%s-help-en', description='Opie Help for %s - English', aux_files_pattern=help_dir + '%s/*')
+}
diff --git a/recipes-opie/opie-help-en/opie-help-en_1.2.5.bb b/recipes-opie/opie-help-en/opie-help-en_1.2.5.bb
new file mode 100644
index 0000000..36aed0d
--- /dev/null
+++ b/recipes-opie/opie-help-en/opie-help-en_1.2.5.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+PR = "r0"
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_help_en_html.tar.bz2;name=split_help_en_html"
+SRC_URI[split_help_en_html.md5sum] = "5ac74b5394fc9afa780f3925862496e3"
+SRC_URI[split_help_en_html.sha256sum] = "64c9dd9aa72ea9939ee9176eb80a0b87d58b43bcdb5e652b581de93e52b506dc"
diff --git a/recipes-opie/opie-help-en/opie-help-en_cvs.bb b/recipes-opie/opie-help-en/opie-help-en_cvs.bb
new file mode 100644
index 0000000..20bcb5d
--- /dev/null
+++ b/recipes-opie/opie-help-en/opie-help-en_cvs.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+OPIE_GIT_PV ?= "1.2.2+cvs${SRCDATE}"
+PV = "${OPIE_GIT_PV}"
+PR = "r1"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=help/en/html "