aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-irc
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/opie-irc
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/opie-irc')
-rw-r--r--recipes-opie/opie-irc/opie-irc.inc22
-rw-r--r--recipes-opie/opie-irc/opie-irc_1.2.5.bb16
-rw-r--r--recipes-opie/opie-irc/opie-irc_cvs.bb9
3 files changed, 47 insertions, 0 deletions
diff --git a/recipes-opie/opie-irc/opie-irc.inc b/recipes-opie/opie-irc/opie-irc.inc
new file mode 100644
index 0000000..269d9c9
--- /dev/null
+++ b/recipes-opie/opie-irc/opie-irc.inc
@@ -0,0 +1,22 @@
+DESCRIPTION = "The Opie IRC client lets you chat on your favorite IRC server using your handheld computer"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+I18N_FILES = "opieirc.ts"
+DEPENDS = "libqtaux2"
+APPNAME = "opieirc"
+#APPTYPE = "binary"
+
+
+S = "${WORKDIR}/${APPNAME}"
+
+inherit opie
+
+# FILES plugins/application/libopieirc.so* bin/opieirc pics/opieirc apps/Applications/opieirc.desktop help/en/html/opieirc.html help/en/html/opieirc
+do_install() {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/pics/${APPNAME}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+ install -d ${D}${palmtopdir}/help/en/html/
+ install -m 0644 ${WORKDIR}/help/en/html/opieirc.html ${D}${palmtopdir}/help/en/html/
+}
+
diff --git a/recipes-opie/opie-irc/opie-irc_1.2.5.bb b/recipes-opie/opie-irc/opie-irc_1.2.5.bb
new file mode 100644
index 0000000..c3d0bc6
--- /dev/null
+++ b/recipes-opie/opie-irc/opie-irc_1.2.5.bb
@@ -0,0 +1,16 @@
+require ${PN}.inc
+
+PR = "r0"
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_noncore_net_opieirc.tar.bz2;name=split_noncore_net_opieirc \
+ http://sources.openembedded.org/opie-1.2.5-split_help.tar.bz2;name=split_help \
+ http://sources.openembedded.org/opie-1.2.5-split_apps.tar.bz2;name=split_apps \
+ http://sources.openembedded.org/opie-1.2.5-split_pics.tar.bz2;name=split_pics"
+SRC_URI[split_noncore_net_opieirc.md5sum] = "9c425f43ec2575925121a31ab988ea67"
+SRC_URI[split_noncore_net_opieirc.sha256sum] = "0bf63dfced107a72458d09a661a386bc4f977709c9fd40217c46f1bece9fa672"
+SRC_URI[split_help.md5sum] = "43393aaa1840e4f6e2c2a3397e451e2a"
+SRC_URI[split_help.sha256sum] = "6e4e3e7d626611a78e34343f88ebd8a6e5e7255be23859b7cd166b2575cbb632"
+SRC_URI[split_apps.md5sum] = "c765d13427e4dc8ee396e4dfed2dbe73"
+SRC_URI[split_apps.sha256sum] = "0fea454d8d286f7febc7449e4a06f73e941e8b22e9bab904a32e57f35479862a"
+SRC_URI[split_pics.md5sum] = "e9b68749d67295f7080a23e39b17335e"
+SRC_URI[split_pics.sha256sum] = "0a7aab6d0bce04d6a9c257d768d8a1a481d38ba527d6e6e50723973789954b4a"
diff --git a/recipes-opie/opie-irc/opie-irc_cvs.bb b/recipes-opie/opie-irc/opie-irc_cvs.bb
new file mode 100644
index 0000000..e9b1f63
--- /dev/null
+++ b/recipes-opie/opie-irc/opie-irc_cvs.bb
@@ -0,0 +1,9 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+PR = "r3"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/net/opieirc \
+ ${OPIE_GIT};protocol=git;subpath=help \
+ ${OPIE_GIT};protocol=git;subpath=apps \
+ ${OPIE_GIT};protocol=git;subpath=pics"