aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-irdaapplet
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/opie-irdaapplet
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/opie-irdaapplet')
-rw-r--r--recipes-opie/opie-irdaapplet/opie-irdaapplet.inc33
-rw-r--r--recipes-opie/opie-irdaapplet/opie-irdaapplet_1.2.5.bb17
-rw-r--r--recipes-opie/opie-irdaapplet/opie-irdaapplet_cvs.bb10
3 files changed, 60 insertions, 0 deletions
diff --git a/recipes-opie/opie-irdaapplet/opie-irdaapplet.inc b/recipes-opie/opie-irdaapplet/opie-irdaapplet.inc
new file mode 100644
index 0000000..ed47c2c
--- /dev/null
+++ b/recipes-opie/opie-irdaapplet/opie-irdaapplet.inc
@@ -0,0 +1,33 @@
+DESCRIPTION = "IrDA Applet"
+SECTION = "opie/applets"
+PRIORITY = "optional"
+LICENSE = "GPL"
+APPNAME = "irdaapplet"
+
+
+S = "${WORKDIR}/${APPNAME}"
+
+inherit opie
+
+pkg_postinst() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi
+if pidof -s qpe >/dev/null; then
+ ${bindir}/qcop QPE/TaskBar "reloadApplets()"
+fi
+}
+
+pkg_postrm() {
+#!/bin/sh
+${bindir}/qcop QPE/TaskBar "reloadApplets()"
+ if [ -n "$D" ]; then false; fi
+}
+
+# FILES plugins/applets/libirdaapplet.so* pics/irdaapplet/* sounds/irdaapplet/*.wav
+do_install() {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -d ${D}${palmtopdir}/sounds/${APPNAME}/
+ install -m 0644 ${WORKDIR}/pics/${APPNAME}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/sounds/${APPNAME}/*.wav ${D}${palmtopdir}/sounds/${APPNAME}/
+}
+
diff --git a/recipes-opie/opie-irdaapplet/opie-irdaapplet_1.2.5.bb b/recipes-opie/opie-irdaapplet/opie-irdaapplet_1.2.5.bb
new file mode 100644
index 0000000..4f90e55
--- /dev/null
+++ b/recipes-opie/opie-irdaapplet/opie-irdaapplet_1.2.5.bb
@@ -0,0 +1,17 @@
+require ${PN}.inc
+
+PR = "r0"
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_core_applets_irdaapplet.tar.bz2;name=split_core_applets_irdaapplet \
+ http://sources.openembedded.org/opie-1.2.5-split_pics.tar.bz2;name=split_pics \
+ http://sources.openembedded.org/opie-1.2.5-split_sounds.tar.bz2;name=split_sounds \
+ http://sources.openembedded.org/opie-1.2.5-split_apps.tar.bz2;name=split_apps \
+ "
+SRC_URI[split_core_applets_irdaapplet.md5sum] = "c25501ed8ebddf7106ee8ba36dc7a91e"
+SRC_URI[split_core_applets_irdaapplet.sha256sum] = "9e44df950292cf9d47b226afdd4681ee8fadbc38cc0de8426d5a00fa01ff98de"
+SRC_URI[split_pics.md5sum] = "e9b68749d67295f7080a23e39b17335e"
+SRC_URI[split_pics.sha256sum] = "0a7aab6d0bce04d6a9c257d768d8a1a481d38ba527d6e6e50723973789954b4a"
+SRC_URI[split_sounds.md5sum] = "b0f2bee8c158f54162e5e74d4d9594df"
+SRC_URI[split_sounds.sha256sum] = "55441675b28209cb2e34ffc0875c6d47aee27bd65dbdb40a223e5fa05c5a7c06"
+SRC_URI[split_apps.md5sum] = "c765d13427e4dc8ee396e4dfed2dbe73"
+SRC_URI[split_apps.sha256sum] = "0fea454d8d286f7febc7449e4a06f73e941e8b22e9bab904a32e57f35479862a"
diff --git a/recipes-opie/opie-irdaapplet/opie-irdaapplet_cvs.bb b/recipes-opie/opie-irdaapplet/opie-irdaapplet_cvs.bb
new file mode 100644
index 0000000..7af53fb
--- /dev/null
+++ b/recipes-opie/opie-irdaapplet/opie-irdaapplet_cvs.bb
@@ -0,0 +1,10 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+PR = r3
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=core/applets/irdaapplet \
+ ${OPIE_GIT};protocol=git;subpath=pics \
+ ${OPIE_GIT};protocol=git;subpath=sounds \
+ ${OPIE_GIT};protocol=git;subpath=apps \
+ "