aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-login
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/opie-login
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/opie-login')
-rw-r--r--recipes-opie/opie-login/files/opie-login.conf2
-rw-r--r--recipes-opie/opie-login/files/opie-session15
-rw-r--r--recipes-opie/opie-login/files/post-session22
-rw-r--r--recipes-opie/opie-login/files/pre-session39
-rw-r--r--recipes-opie/opie-login/opie-login.inc31
-rw-r--r--recipes-opie/opie-login/opie-login_1.2.5.bb15
-rw-r--r--recipes-opie/opie-login/opie-login_cvs.bb11
7 files changed, 135 insertions, 0 deletions
diff --git a/recipes-opie/opie-login/files/opie-login.conf b/recipes-opie/opie-login/files/opie-login.conf
new file mode 100644
index 0000000..13195b1
--- /dev/null
+++ b/recipes-opie/opie-login/files/opie-login.conf
@@ -0,0 +1,2 @@
+[General]
+AutoLogin = root
diff --git a/recipes-opie/opie-login/files/opie-session b/recipes-opie/opie-login/files/opie-session
new file mode 100644
index 0000000..f2425f6
--- /dev/null
+++ b/recipes-opie/opie-login/files/opie-session
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+if [ -x /usr/bin/ssh-agent ]; then
+ SSHAGENT=/usr/bin/ssh-agent
+else
+ SSHAGENT=""
+fi
+
+if [ -x $OPIEDIR/bin/opie-sh-ssh-askpass.sh ]; then
+ export SSH_ASKPASS=$OPIEDIR/bin/opie-sh-ssh-askpass.sh
+fi
+
+$OPIEDIR/bin/opie-reorgfiles
+
+$SSHAGENT $OPIEDIR/bin/qpe
diff --git a/recipes-opie/opie-login/files/post-session b/recipes-opie/opie-login/files/post-session
new file mode 100644
index 0000000..47dc597
--- /dev/null
+++ b/recipes-opie/opie-login/files/post-session
@@ -0,0 +1,22 @@
+#!/bin/sh
+
+permout ()
+{
+ if [ -e $1 ]
+ then
+ chown root $1
+ else
+ echo Warning: $1 does not exist.
+ return 1
+ fi
+}
+
+if [ -e /proc/hal/model ]; then
+ for i in /dev/sound/dsp /dev/sound/mixer /dev/touchscreen/* /dev/fb/0 /dev/vc/0; do
+ permout $i
+ done
+else
+ for i in /dev/dsp /dev/dsp1 /dev/mixer /dev/ts /dev/fb0 /dev/sharp* /dev/collie*; do
+ permout $i
+ done
+fi
diff --git a/recipes-opie/opie-login/files/pre-session b/recipes-opie/opie-login/files/pre-session
new file mode 100644
index 0000000..2fdf7e9
--- /dev/null
+++ b/recipes-opie/opie-login/files/pre-session
@@ -0,0 +1,39 @@
+#!/bin/sh
+
+USER=$1
+
+# NOTE about permissions in OpenZaurus
+# The devices in question here by default
+# are accessible to everyone in the group in
+# question. We wish to ensure that, as a policy
+# choice, a login to opie makes access to these
+# devices exclusive by 1) changing device ownership
+# to the user, and 2) removing group access.
+#
+# A better implementation would probably be to store
+# existing device permissions at load time, and restore
+# them at exit, rather than making assumptions about
+# user/group ownership, or permissions.
+
+permin ()
+{
+ if [ -e $1 ]
+ then
+ chown $USER $1
+ else
+ echo Warning: $1 does not exist.
+ return 1
+ fi
+}
+
+if [ -e /proc/hal/model ]; then
+ # fix for misconfigured devfsd
+ chmod +x /dev/sound /dev/touchscreen /dev/fb /dev/vc
+ for i in /dev/sound/dsp /dev/sound/mixer /dev/touchscreen/* /dev/fb/0 /dev/vc/0; do
+ permin $i
+ done
+else
+ for i in /dev/dsp/* /dev/dsp1 /dev/mixer /dev/ts /dev/fb0 /dev/sharp* /dev/collie*; do
+ permin $i
+ done
+fi
diff --git a/recipes-opie/opie-login/opie-login.inc b/recipes-opie/opie-login/opie-login.inc
new file mode 100644
index 0000000..ced9fd7
--- /dev/null
+++ b/recipes-opie/opie-login/opie-login.inc
@@ -0,0 +1,31 @@
+DESCRIPTION = "Opie Login Manager (similar to gdm, xdm or kdm)"
+SECTION = "opie/base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RRECOMMENDS_${PN} = "opie-logoutapplet"
+APPNAME = "opie-login"
+
+BROKEN = "1"
+
+S = "${WORKDIR}/${APPNAME}"
+
+inherit opie
+
+EXTRA_QMAKEVARS_POST_append = " LIBS-=-lpam"
+EXTRA_QMAKEVARS_POST_append = " DEFINES-=USEPAM"
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin
+ install -d ${D}${palmtopdir}/etc
+ install -d ${D}${palmtopdir}/share/opie-login
+
+ install -m 755 ${WORKDIR}/${PN}/opie-login ${D}${palmtopdir}/bin
+ install -m 644 ${WORKDIR}/*-session ${D}${palmtopdir}/share/opie-login
+ install -m 644 ${WORKDIR}/opie-login.conf ${D}${palmtopdir}/etc
+}
+
+do_configure() {
+ install -d "${WORKDIR}/apps"
+ ln -s "${WORKDIR}/calibrate" "${WORKDIR}/apps/calibrate"
+ palmtop_do_configure
+}
diff --git a/recipes-opie/opie-login/opie-login_1.2.5.bb b/recipes-opie/opie-login/opie-login_1.2.5.bb
new file mode 100644
index 0000000..22dc8af
--- /dev/null
+++ b/recipes-opie/opie-login/opie-login_1.2.5.bb
@@ -0,0 +1,15 @@
+require ${PN}.inc
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_core_${APPNAME}.tar.bz2;name=split_core_appname \
+ http://sources.openembedded.org/opie-1.2.5-split_core_apps_calibrate.tar.bz2;name=split_core_apps_calibrate \
+ http://sources.openembedded.org/opie-1.2.5-split_core_launcher.tar.bz2;name=split_core_launcher \
+ file://opie-session \
+ file://post-session \
+ file://pre-session \
+ file://opie-login.conf"
+SRC_URI[split_core_appname.md5sum] = "88d0bdbc49a59529ce43880f6df82212"
+SRC_URI[split_core_appname.sha256sum] = "263a3734c3f9aadacb9d84ff1ae38b717f1eadd66c59c227769a7e26309fb85d"
+SRC_URI[split_core_apps_calibrate.md5sum] = "ee5e06b781e92f01271d883f91f101b0"
+SRC_URI[split_core_apps_calibrate.sha256sum] = "5e0164a195a166fd15451164edf8a44d8f3a9f81dcf3edc3a8975f24bd4b45b6"
+SRC_URI[split_core_launcher.md5sum] = "cd3708a2d074f108d81ffea590995725"
+SRC_URI[split_core_launcher.sha256sum] = "fca1501398f1e4d0690455b145b17a68287de422592bca73c2afdf6762d021ce"
diff --git a/recipes-opie/opie-login/opie-login_cvs.bb b/recipes-opie/opie-login/opie-login_cvs.bb
new file mode 100644
index 0000000..9c1f0e4
--- /dev/null
+++ b/recipes-opie/opie-login/opie-login_cvs.bb
@@ -0,0 +1,11 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=core/${APPNAME} \
+ ${OPIE_GIT};protocol=git;subpath=core/apps/calibrate \
+ ${OPIE_GIT};protocol=git;subpath=core/launcher \
+ file://opie-session \
+ file://post-session \
+ file://pre-session \
+ file://opie-login.conf"