aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-symlinker
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/opie-symlinker
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/opie-symlinker')
-rw-r--r--recipes-opie/opie-symlinker/opie-symlinker.inc17
-rw-r--r--recipes-opie/opie-symlinker/opie-symlinker_1.2.5.bb5
-rw-r--r--recipes-opie/opie-symlinker/opie-symlinker_cvs.bb5
3 files changed, 27 insertions, 0 deletions
diff --git a/recipes-opie/opie-symlinker/opie-symlinker.inc b/recipes-opie/opie-symlinker/opie-symlinker.inc
new file mode 100644
index 0000000..713ead3
--- /dev/null
+++ b/recipes-opie/opie-symlinker/opie-symlinker.inc
@@ -0,0 +1,17 @@
+DESCRIPTION = "Enables apps on external media"
+SECTION = "opie/base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+APPNAME = "opie-update-symlinks"
+APPTYPE = "binary"
+
+
+S = "${WORKDIR}/symlinker"
+
+inherit opie
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin/
+ install -m 0755 ${S}/opie-update-symlinks ${D}${palmtopdir}/bin/
+}
+
diff --git a/recipes-opie/opie-symlinker/opie-symlinker_1.2.5.bb b/recipes-opie/opie-symlinker/opie-symlinker_1.2.5.bb
new file mode 100644
index 0000000..64e10a4
--- /dev/null
+++ b/recipes-opie/opie-symlinker/opie-symlinker_1.2.5.bb
@@ -0,0 +1,5 @@
+require ${PN}.inc
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_core_symlinker.tar.bz2;name=split_core_symlinker"
+SRC_URI[split_core_symlinker.md5sum] = "d3be755591dfcd4a45e1de337a05a43b"
+SRC_URI[split_core_symlinker.sha256sum] = "7d5c5b02f1623aadc2af2134f7bb53ef8d8fbc8a264eff74618f65aab6c44aef"
diff --git a/recipes-opie/opie-symlinker/opie-symlinker_cvs.bb b/recipes-opie/opie-symlinker/opie-symlinker_cvs.bb
new file mode 100644
index 0000000..334a1dc
--- /dev/null
+++ b/recipes-opie/opie-symlinker/opie-symlinker_cvs.bb
@@ -0,0 +1,5 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=core/symlinker "