aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-volumeapplet
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/opie-volumeapplet
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/opie-volumeapplet')
-rw-r--r--recipes-opie/opie-volumeapplet/opie-volumeapplet.inc29
-rw-r--r--recipes-opie/opie-volumeapplet/opie-volumeapplet_1.2.5.bb10
-rw-r--r--recipes-opie/opie-volumeapplet/opie-volumeapplet_cvs.bb7
3 files changed, 46 insertions, 0 deletions
diff --git a/recipes-opie/opie-volumeapplet/opie-volumeapplet.inc b/recipes-opie/opie-volumeapplet/opie-volumeapplet.inc
new file mode 100644
index 0000000..3bb619f
--- /dev/null
+++ b/recipes-opie/opie-volumeapplet/opie-volumeapplet.inc
@@ -0,0 +1,29 @@
+DESCRIPTION = "Volume applet"
+SECTION = "opie/applets"
+PRIORITY = "optional"
+LICENSE = "GPL"
+APPNAME = "volumeapplet"
+
+
+S = "${WORKDIR}/${APPNAME}"
+
+inherit opie
+
+pkg_postinst() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi
+if pidof -s qpe >/dev/null; then
+ ${bindir}/qcop QPE/TaskBar "reloadApplets()"
+fi
+}
+
+pkg_postrm() {
+#!/bin/sh
+${bindir}/qcop QPE/TaskBar "reloadApplets()"
+ if [ -n "$D" ]; then false; fi
+}
+
+# FILES plugins/applets/libvolumeapplet.so*
+do_install() {
+}
+
diff --git a/recipes-opie/opie-volumeapplet/opie-volumeapplet_1.2.5.bb b/recipes-opie/opie-volumeapplet/opie-volumeapplet_1.2.5.bb
new file mode 100644
index 0000000..e881c36
--- /dev/null
+++ b/recipes-opie/opie-volumeapplet/opie-volumeapplet_1.2.5.bb
@@ -0,0 +1,10 @@
+require ${PN}.inc
+
+PR = "r0"
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_core_applets_volumeapplet.tar.bz2;name=split_core_applets_volumeapplet \
+ http://sources.openembedded.org/opie-1.2.5-split_apps.tar.bz2;name=split_apps"
+SRC_URI[split_core_applets_volumeapplet.md5sum] = "5ebd5673372d2927afbc9ad1d8cf5d48"
+SRC_URI[split_core_applets_volumeapplet.sha256sum] = "d80c2f63c21f4766c781e87e76033e984282fd19586b4eae3641b6cff5228716"
+SRC_URI[split_apps.md5sum] = "c765d13427e4dc8ee396e4dfed2dbe73"
+SRC_URI[split_apps.sha256sum] = "0fea454d8d286f7febc7449e4a06f73e941e8b22e9bab904a32e57f35479862a"
diff --git a/recipes-opie/opie-volumeapplet/opie-volumeapplet_cvs.bb b/recipes-opie/opie-volumeapplet/opie-volumeapplet_cvs.bb
new file mode 100644
index 0000000..b7671e8
--- /dev/null
+++ b/recipes-opie/opie-volumeapplet/opie-volumeapplet_cvs.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+PR = "r1"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=core/applets/volumeapplet \
+ ${OPIE_GIT};protocol=git;subpath=apps"