aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/keyring
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/keyring
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/keyring')
-rw-r--r--recipes-qtopia/keyring/keyring-0.6.8/keyring-0.6.8-datatype.patch93
-rw-r--r--recipes-qtopia/keyring/keyring_0.6.8.bb39
2 files changed, 132 insertions, 0 deletions
diff --git a/recipes-qtopia/keyring/keyring-0.6.8/keyring-0.6.8-datatype.patch b/recipes-qtopia/keyring/keyring-0.6.8/keyring-0.6.8-datatype.patch
new file mode 100644
index 0000000..9f0a236
--- /dev/null
+++ b/recipes-qtopia/keyring/keyring-0.6.8/keyring-0.6.8-datatype.patch
@@ -0,0 +1,93 @@
+diff -Naru Keyring.orig/accountlist.cpp Keyring/accountlist.cpp
+--- Keyring.orig/accountlist.cpp 2002-09-29 17:24:09.000000000 +0200
++++ Keyring/accountlist.cpp 2007-06-05 15:46:59.000000000 +0200
+@@ -314,7 +314,7 @@
+ */
+ void AccountList::resetTimer(){
+ mSeconds=mTimerStart;
+- mStartTime = time(NULL);
++ mStartTime = (time_t*)time(NULL);
+ wLCD->display(mSeconds);
+ }
+
+@@ -390,20 +390,20 @@
+ //if so and it has expired, lock keyring.
+ if(mTimerViewingAC && mTimerEnabled){
+ //Timer has expired
+- if((time(NULL)-mStartTime) > mTimerStart){
++ if((time(NULL)-(time_t)mStartTime) > mTimerStart){
+ lock();
+ } else {
+ //Timer needs to be updated
+ time_t diff=time(NULL)-viewtime;
+ mSeconds=mSeconds-diff;
+- mStartTime = time(NULL)-(mTimerStart-mSeconds);
++ mStartTime = (time_t*)time(NULL)-(mTimerStart-mSeconds);
+ mUpdateTimer->start(500,false);
+ wLCD->display(mSeconds);
+ }
+ } else {
+ if(mTimerEnabled){
+ mUpdateTimer->start(500,false);
+- mStartTime = time(NULL)-(mTimerStart-mSeconds);
++ mStartTime = (time_t*)time(NULL)-(mTimerStart-mSeconds);
+ }
+ }
+
+@@ -432,7 +432,7 @@
+ if(mTimerEnabled)
+ mUpdateTimer->start(500,false);
+ mSeconds=mTimerStart;
+- mStartTime = time(NULL);
++ mStartTime = (time_t*)time(NULL);
+ updateCountDown();
+
+ //Let's be a bastard and bitch if the
+@@ -463,11 +463,11 @@
+ void AccountList::updateCountDown(){
+ wLCD->display(mSeconds);
+ if(mSeconds==0 ||
+- (((time(NULL)-mStartTime) > mTimerStart) && mTimerPowerOff)){
++ (((time(NULL)-(time_t)mStartTime) > mTimerStart) && mTimerPowerOff)){
+ lock();
+ return;
+ }
+- mSeconds=mTimerStart-(time(NULL)-mStartTime);
++ mSeconds=mTimerStart-(time(NULL)-(time_t)mStartTime);
+ }
+
+ void AccountList::selectionChanged(QListViewItem *item){
+@@ -548,20 +548,20 @@
+ //if so and it has expired, lock keyring.
+ if(mTimerViewingAC && mTimerEnabled){
+ //Timer has expired
+- if((time(NULL)-mStartTime) > mTimerStart){
++ if((time(NULL)-(time_t)mStartTime) > mTimerStart){
+ lock();
+ } else {
+ //Timer needs to be updated
+- time_t diff=time(NULL)-viewtime;
++ time_t diff = time(NULL)-(time_t)viewtime;
+ mSeconds=mSeconds-diff;
+- mStartTime = time(NULL)-(mTimerStart-mSeconds);
++ mStartTime = (time_t*)time(NULL)-(mTimerStart-mSeconds);
+ mUpdateTimer->start(500,false);
+ wLCD->display(mSeconds);
+ }
+ } else {
+ if(mTimerEnabled){
+ mUpdateTimer->start(500,false);
+- mStartTime = time(NULL)-(mTimerStart-mSeconds);
++ mStartTime = (time_t*)time(NULL)-(mTimerStart-mSeconds);
+ }
+ }
+ delete qd;
+@@ -627,7 +627,7 @@
+
+ if(mTimerEnabled){
+ mUpdateTimer->start(500,false);
+- mStartTime = time(NULL)-(mTimerStart-mSeconds);
++ mStartTime = (time_t*)time(NULL)-(mTimerStart-mSeconds);
+ }
+
+ showAccountList();
diff --git a/recipes-qtopia/keyring/keyring_0.6.8.bb b/recipes-qtopia/keyring/keyring_0.6.8.bb
new file mode 100644
index 0000000..3908006
--- /dev/null
+++ b/recipes-qtopia/keyring/keyring_0.6.8.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "Stores accounts and passwords in an encrypted file."
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "gdbm"
+PR = "r2"
+
+SRC_URI = "http://www.scrypt.net/~celer/kweb/Keyring-0.6.8.tgz \
+ file://keyring-0.6.8-datatype.patch"
+S = "${WORKDIR}/Keyring"
+
+inherit palmtop
+
+QPEDIR = "${OPIEDIR}"
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Applications \
+ ${D}${palmtopdir}/pics/keyring
+ install -m 0755 keyring ${D}${palmtopdir}/bin/
+ install -m 0644 keyring.desktop \
+ ${D}${palmtopdir}/apps/Applications/
+ install -m 0644 ${S}/Keyring.png \
+ ${S}/keyring-pwlist.png \
+ ${D}${palmtopdir}/pics/
+
+ # The following should appear in an assoicated DOC package.
+
+ install -d ${D}${palmtopdir}/help/html
+ install -m 0644 ${S}/*.html ${D}${palmtopdir}/help/html/
+}
+
+PACKAGES = "${PN}-dbg ${PN} ${PN}-help"
+FILES_${PN} = " ${palmtopdir}${base_bindir} ${palmtopdir}/apps ${palmtopdir}/pics"
+FILES_${PN}-help = " ${palmtopdir}/help/html"
+
+
+SRC_URI[md5sum] = "0f429212fdcfd99efe6bfd3904adece8"
+SRC_URI[sha256sum] = "272ddac7f039d12938f50c281f42941d6dea7ab940f1b3b3dd5ab28572678bd4"