aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/qpe-games/crossword_0.0.3.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/qpe-games/crossword_0.0.3.bb
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/qpe-games/crossword_0.0.3.bb')
-rw-r--r--recipes-qtopia/qpe-games/crossword_0.0.3.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-qtopia/qpe-games/crossword_0.0.3.bb b/recipes-qtopia/qpe-games/crossword_0.0.3.bb
new file mode 100644
index 0000000..5b82438
--- /dev/null
+++ b/recipes-qtopia/qpe-games/crossword_0.0.3.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Checkers"
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+AUTHOR = "Robert Ernst"
+HOMEPAGE = "http://www.linux-solutions.at/projects/zaurus/games-Crossword.html"
+
+SRC_URI = "http://handhelds.org/~zecke/oe_packages/crossword_V0.0.3.tar.gz \
+ file://crossword.patch"
+
+PR = "r1"
+
+PV = "0.0.3"
+S = "${WORKDIR}/crossword_V${PV}"
+
+APPNAME = "crossword"
+APPTYPE = "binary"
+APPDESKTOP = "${S}"
+
+do_install () {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${S}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+
+}
+
+pkg_postinst() {
+#!/bin/sh
+
+MIMEFILE=/opt/QtPalmtop/etc/mime.types
+
+grep -q application/puz $MIMEFILE 2>/dev/null || printf "application/crossword\t\tpuz tpz\n" >> $MIMEFILE
+}
+
+inherit opie
+
+SRC_URI[md5sum] = "659d5c53cbace53f44fe7acb666bfe33"
+SRC_URI[sha256sum] = "8b718c344cf19417447cbc16867d2e04434654c13b330598b96720ead146b961"