aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/snes9x/snes9x/makefile.patch
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/snes9x/snes9x/makefile.patch
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/snes9x/snes9x/makefile.patch')
-rw-r--r--recipes-qtopia/snes9x/snes9x/makefile.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-qtopia/snes9x/snes9x/makefile.patch b/recipes-qtopia/snes9x/snes9x/makefile.patch
new file mode 100644
index 0000000..dc99864
--- /dev/null
+++ b/recipes-qtopia/snes9x/snes9x/makefile.patch
@@ -0,0 +1,39 @@
+--- snes9x-1.43-dev-src/snes9x/Makefile.in.old 2004-10-02 17:34:58.000000000 +0100
++++ snes9x-1.43-dev-src/snes9x/Makefile.in 2004-10-02 17:42:25.000000000 +0100
+@@ -142,7 +142,7 @@
+ #INCLUDES = -I../zlib @XINCLUDES@
+ INCLUDES = @XINCLUDES@
+
+-OPTIMISE = @OPTIMIZE@
++OPTIMISE = $(filter-out @OPTIMIZE@,-pedantic)
+
+ #OPTIMISE=-g -fno-exceptions
+
+@@ -165,7 +165,7 @@
+ $(KREEDDEFINES) \
+ $(SDD1DEFINES) \
+ $(JOYDEFINES) \
+--DNO_INLINE_SET_GET @SYSDEFINES@
++-DNO_INLINE_SET_GET @SYSDEFINES@ $(OECFLAGS)
+
+ #-DOLD_COLOUR_BLENDING
+ #-DSOUND
+@@ -204,15 +204,15 @@
+ #ggisnes9x
+ #xf86snes9x
+
+-offsets: offsets.o
+- $(CCC) $(INCLUDES) -o $@ offsets.o
++offsets: offsets.cpp
++ $(BUILD_CXX) $(INCLUDES) -o $@ $<
+ ./offsets >i386/offsets.h
+
+ #../zlib/libz.a:
+ # cd ../zlib && sh ./configure && make
+
+ snes9x: $(OBJECTS) unix/x11.o $(AIDOOBJS) $(GUIOBJS)
+- $(CCC) $(INCLUDES) -o $@ $(OBJECTS) $(AIDOOBJS) $(GLIDEOBJS) $(OPENGLOBJS) unix/x11.o $(GUIOBJS) $(LDLIBS) $(GLIDELIBS) $(OPENGLLIBS) $(GUILIBS) @SYSLIBS@ -lXext -lX11 $(EXTRALIBS) -lm
++ $(CCC) $(INCLUDES) -o $@ $(OBJECTS) $(AIDOOBJS) $(GLIDEOBJS) $(OPENGLOBJS) unix/x11.o $(GUIOBJS) $(OELDFLAGS) $(LDLIBS) $(GLIDELIBS) $(OPENGLLIBS) $(GUILIBS) @SYSLIBS@ -lXext -lX11 $(EXTRALIBS) -lm
+
+ ssnes9x: $(OBJECTS) unix/svga.o
+ $(CCC) $(INCLUDES) -o $@ $(OBJECTS) $(GLIDEOBJS) unix/svga.o $(LDLIBS) $(GLIDELIBS) -lvga -lvgagl $(EXTRALIBS) -lm