aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/zbedic/zbedic_1.2.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/zbedic/zbedic_1.2.bb
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/zbedic/zbedic_1.2.bb')
-rw-r--r--recipes-qtopia/zbedic/zbedic_1.2.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-qtopia/zbedic/zbedic_1.2.bb b/recipes-qtopia/zbedic/zbedic_1.2.bb
new file mode 100644
index 0000000..216fc00
--- /dev/null
+++ b/recipes-qtopia/zbedic/zbedic_1.2.bb
@@ -0,0 +1,46 @@
+DESCRIPTION = "A dictionary application for Qt/E based Palmtop Environments"
+HOMEPAGE = "http://bedic.sourceforge.net/"
+AUTHOR = "Rafal Mantiuk <rafm@users.sourceforge.net>"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "libbedic"
+APPTYPE = "binary"
+APPDESKTOP = "${WORKDIR}/misc"
+PR = "r3"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/bedic/zbedic_${PV}-2.tgz;subdir=${BPN}-${PV} \
+ file://opie-icons.patch \
+ file://qtopia17.patch"
+
+inherit opie
+export OE_QMAKE_LINK="${CXX}"
+export OE_QMAKE_CXXFLAGS=" -DVERSION=\\"${PV}.2\\" -DPREFIX_PATH=\\"/usr\\""
+
+EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${STAGING_INCDIR}/libbedic LIBS+=-lbedic LIBS+=-lsqlite3 TARGET=zbedic"
+
+do_configure_prepend() {
+ rm -f Makefile
+ qmake -project
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/zbedic/
+ install -d ${D}${palmtopdir}/help/html/
+ # we copy small icons - in other way QVGA users will complain
+ install -m 0644 ${S}/misc/small_icons/*.png ${D}${palmtopdir}/pics/zbedic/
+ install -m 0644 ${S}/misc/large_icons/zbedic.png ${D}${palmtopdir}/pics/
+ install -m 0644 ${S}/doc/manual/*.html ${D}${palmtopdir}/help/html/
+ rm ${D}${palmtopdir}/pics/zbedic/zbedic.png
+
+ # those ones are taken from OPIE so they have proper size (depend on device)
+ rm ${D}${palmtopdir}/pics/zbedic/back.png
+ rm ${D}${palmtopdir}/pics/zbedic/forward.png
+}
+
+PACKAGES = "${PN}-dbg ${PN}-doc ${PN} ${PN}-dev"
+
+FILES_${PN}-doc += "${palmtopdir}/help"
+
+SRC_URI[md5sum] = "c7e8e267567a96cff7920a0365978c4d"
+SRC_URI[sha256sum] = "b991cc5635849353081c2a3350142484763323bc58bfa49b62285645aac129b9"