aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/xqtlauncher/xqtlauncher.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qtopia/xqtlauncher/xqtlauncher.bb')
-rw-r--r--recipes-qtopia/xqtlauncher/xqtlauncher.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-qtopia/xqtlauncher/xqtlauncher.bb b/recipes-qtopia/xqtlauncher/xqtlauncher.bb
new file mode 100644
index 0000000..b4203d4
--- /dev/null
+++ b/recipes-qtopia/xqtlauncher/xqtlauncher.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "xqtlauncher integrates X/Qt2 nicely into opie. You can launch applications with it from opies menue"
+HOMEPAGE = "http://angstrom-distribution.org/"
+LICENSE = "GPL"
+PR = "r3"
+
+RDEPENDS_${PN} = "xqt2 xorg-minimal-fonts"
+
+SRC_URI = "file://dot.directory \
+ file://startxqt \
+ file://startxqt-wrapper \
+ file://xqtlauncher-convert.sh \
+ file://xqtlauncher-cleanup.sh \
+ file://convert.desktop \
+ file://cleanup.desktop \
+ file://xqtlauncher "
+
+do_install() {
+ cd ${WORKDIR}
+ install -d ${D}${bindir}
+ install -m 0755 startxqt startxqt-wrapper xqtlauncher ${D}${bindir}
+ install -d ${D}${palmtopdir}/apps/XQt2/
+ install -m 0644 dot.directory ${D}${palmtopdir}/apps/XQt2/.directory
+ install -m 0644 convert.desktop cleanup.desktop ${D}${palmtopdir}/apps/XQt2/
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 startxqt startxqt-wrapper xqtlauncher xqtlauncher-cleanup.sh xqtlauncher-convert.sh ${D}${sysconfdir}/init.d/
+ install -d ${D}${sysconfdir}/rc5.d/
+ ln -sf ../init.d/xqtlauncher-convert.sh ${D}${sysconfdir}/rc5.d/S98xqtlauncher-convert
+ ln -sf ../init.d/xqtlauncher-cleanup.sh ${D}${sysconfdir}/rc5.d/S98xqtlauncher-cleanup
+}
+
+FILES_${PN} += "${palmtopdir}/apps/XQt2 \
+ ${palmtopdir}/apps/XQt2/convert.desktop \
+ ${palmtopdir}/apps/XQt2/cleanup.desktop \
+ ${palmtopdir}/apps/XQt2/.directory "