summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2013-05-14 14:23:29 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-16 00:09:49 +0300
commitec89446cb41c2be6aa76904f972d21611df90a5f (patch)
tree91149484f052ddf2b21a67f253fa6b8583e6524e
parent39537e01a53b25741171f68aa05137aee9ba392b (diff)
downloadopenembedded-core-contrib-ec89446cb41c2be6aa76904f972d21611df90a5f.tar.gz
systemd: make udev-hwdb postinstall run on host
Run udevadm inside qemu in order to create the HW database index on host. The alternative would be to build a native version of udevadm which would imply several things: split out systemd recipe, create a common inc file and create a new recipe for udevadm native. However, this latter solution might also add up to the build time (the native recipe would need to run configure, make udevadm, install), besides the time spent in the actual postinstall... So, having the postinstall run through qemu is a good trade-off. [YOCTO #4341] (From OE-Core rev: 0f6c0ed7888603c8d026a671f2acb1515ce799bf) Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/systemd/systemd_199.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/meta/recipes-core/systemd/systemd_199.bb b/meta/recipes-core/systemd/systemd_199.bb
index fadc385fb2..b1cc0465ef 100644
--- a/meta/recipes-core/systemd/systemd_199.bb
+++ b/meta/recipes-core/systemd/systemd_199.bb
@@ -11,12 +11,12 @@ PROVIDES = "udev"
PE = "1"
PR = "r4"
-DEPENDS = "kmod docbook-sgml-dtd-4.1-native intltool-native gperf-native acl readline dbus libcap libcgroup tcp-wrappers glib-2.0"
+DEPENDS = "kmod docbook-sgml-dtd-4.1-native intltool-native gperf-native acl readline dbus libcap libcgroup tcp-wrappers glib-2.0 qemu-native"
DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
SECTION = "base/shell"
-inherit gtk-doc useradd pkgconfig autotools perlnative update-rc.d update-alternatives
+inherit gtk-doc useradd pkgconfig autotools perlnative update-rc.d update-alternatives qemu
SRC_URI = "http://www.freedesktop.org/software/systemd/systemd-${PV}.tar.xz \
file://touchscreen.rules \
@@ -280,10 +280,11 @@ ALTERNATIVE_PRIORITY[poweroff] ?= "300"
pkg_postinst_udev-hwdb () {
if test -n "$D"; then
- exit 1
+ ${@qemu_run_binary(d, '$D', '${base_bindir}/udevadm')} hwdb --update \
+ --root $D
+ else
+ udevadm hwdb --update
fi
-
- udevadm hwdb --update
}
pkg_prerm_udev-hwdb () {