summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/libpcap/libpcap_1.7.4.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2015-11-18 11:34:36 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-01 21:30:57 +0000
commit0256743e7ad6e430aa2380ce51c84b3ce5928a1f (patch)
tree393dca2875c4c59c379f6093af90659bfc9027f7 /meta/recipes-connectivity/libpcap/libpcap_1.7.4.bb
parent814b7589ea857806db7e3d2a09cf5f52df5afd76 (diff)
downloadopenembedded-core-contrib-0256743e7ad6e430aa2380ce51c84b3ce5928a1f.tar.gz
libpcap: update to 1.7.4
Update libpcap from version 1.6.2 to 1.7.4 LICENSE checksum has changed because of the removal of additional spaces in the file. Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-connectivity/libpcap/libpcap_1.7.4.bb')
-rw-r--r--meta/recipes-connectivity/libpcap/libpcap_1.7.4.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/libpcap/libpcap_1.7.4.bb b/meta/recipes-connectivity/libpcap/libpcap_1.7.4.bb
new file mode 100644
index 0000000000..8d12b25213
--- /dev/null
+++ b/meta/recipes-connectivity/libpcap/libpcap_1.7.4.bb
@@ -0,0 +1,26 @@
+require libpcap.inc
+
+SRC_URI += "file://aclocal.patch \
+ file://libpcap-pkgconfig-support.patch \
+ "
+SRC_URI[md5sum] = "b2e13142bbaba857ab1c6894aedaf547"
+SRC_URI[sha256sum] = "7ad3112187e88328b85e46dce7a9b949632af18ee74d97ffc3f2b41fe7f448b0"
+
+#
+# make install doesn't cover the shared lib
+# make install-shared is just broken (no symlinks)
+#
+
+do_configure_prepend () {
+ #remove hardcoded references to /usr/include
+ sed 's|\([ "^'\''I]\+\)/usr/include/|\1${STAGING_INCDIR}/|g' -i ${S}/configure.in
+}
+
+do_install_prepend () {
+ install -d ${D}${libdir}
+ install -d ${D}${bindir}
+ oe_runmake install-shared DESTDIR=${D}
+ oe_libinstall -a -so libpcap ${D}${libdir}
+ sed "s|@VERSION@|${PV}|" -i ${B}/libpcap.pc
+ install -D -m 0644 libpcap.pc ${D}${libdir}/pkgconfig/libpcap.pc
+}