summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/eglibc_2.13.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-12-09 11:19:35 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-12 21:50:10 +0000
commit9244a3b0565fd52d7973fda42a4f706b16240316 (patch)
tree5c7339e9044404c3c68fb2cb13983a1e02ec5344 /meta/recipes-core/eglibc/eglibc_2.13.bb
parentc09c6e61991b30c99d68fa6c2e5639d490a65e89 (diff)
downloadopenembedded-core-contrib-9244a3b0565fd52d7973fda42a4f706b16240316.tar.gz
eglibc: Generate cross testing script during install
EGLIBC has long had cross testing capability, so use that there are few steps needed on setting up the target as well as the build host. This patch tries to generate a script with all the needed environment on build host system To use this script one needs to setup the target as described in the testing intructions of eglibc and then this script can directly interface to the target and run the tests from eglibc's build directory. To run this script bash <script> username@testing_hostname/ip The output can be dumped into a log file for later viewing and checked for "Error " to see the failed tests Removes INC_PR its not used anywhere Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-core/eglibc/eglibc_2.13.bb')
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.13.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/meta/recipes-core/eglibc/eglibc_2.13.bb b/meta/recipes-core/eglibc/eglibc_2.13.bb
index 955c4ec4b9..9d3ec85af6 100644
--- a/meta/recipes-core/eglibc/eglibc_2.13.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.13.bb
@@ -3,7 +3,7 @@ require eglibc.inc
SRCREV = "15508"
DEPENDS += "gperf-native"
-PR = "r18"
+PR = "r19"
PR_append = "+svnr${SRCPV}"
EGLIBC_BRANCH="eglibc-2_13"
@@ -207,10 +207,11 @@ do_compile () {
done
)
echo "Adjust ldd script"
- [ -z "${RTLDLIST}" ] && return
- sed -i ${B}/elf/ldd -e 's#^\(RTLDLIST=\)"\(.*\)"$#\1\2#'
- sed -i ${B}/elf/ldd -e 's#^\(RTLDLIST=\)\(.*\)$#\1"${RTLDLIST} \2"#'
-
+ if [ -n "${RTLDLIST}" ]
+ then
+ sed -i ${B}/elf/ldd -e 's#^\(RTLDLIST=\)"\(.*\)"$#\1\2#'
+ sed -i ${B}/elf/ldd -e 's#^\(RTLDLIST=\)\(.*\)$#\1"${RTLDLIST} \2"#'
+ fi
}
require eglibc-package.inc