summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/initrdscripts
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2013-06-28 15:48:52 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-28 10:43:17 +0100
commitba5e437bc7335468a70ea293496f78e1a9d66287 (patch)
tree194a168ba2b74b1663d7257bbb4bf32201976753 /meta/recipes-core/initrdscripts
parent17890ebd637da0b3bf78804002d8b4f0ace078d2 (diff)
downloadopenembedded-core-contrib-ba5e437bc7335468a70ea293496f78e1a9d66287.tar.gz
initrdscripts: unionfs cleanup
The unionfs has been disabled for more than a year and it's not going to be used any more. This patch cleans up the unionfs related code. [YOCTO #4761] [YOCTO #1487] Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/initrdscripts')
-rw-r--r--meta/recipes-core/initrdscripts/files/init-live.sh22
-rw-r--r--meta/recipes-core/initrdscripts/initramfs-live-boot_1.0.bb7
2 files changed, 3 insertions, 26 deletions
diff --git a/meta/recipes-core/initrdscripts/files/init-live.sh b/meta/recipes-core/initrdscripts/files/init-live.sh
index 82042bf2ee..ca4135141f 100644
--- a/meta/recipes-core/initrdscripts/files/init-live.sh
+++ b/meta/recipes-core/initrdscripts/files/init-live.sh
@@ -7,7 +7,6 @@ ROOT_IMAGE="rootfs.img"
MOUNT="/bin/mount"
UMOUNT="/bin/umount"
ISOLINUX=""
-UNIONFS="no"
# Copied from initramfs-framework. The core of this script probably should be
# turned into initramfs-framework modules to reduce duplication.
@@ -142,25 +141,10 @@ case $label in
boot)
mkdir $ROOT_MOUNT
mknod /dev/loop0 b 7 0 2>/dev/null
-
-
- if [ "$UNIONFS" = "yes" ]; then
- mkdir /rootfs-tmp
-
- if ! $MOUNT -o rw,loop,noatime,nodiratime /media/$i/$ISOLINUX/$ROOT_IMAGE /rootfs-tmp ; then
- fatal "Could not mount rootfs image"
- else
- mkdir /cow
- mount -t tmpfs -o rw,noatime,mode=755 tmpfs /cow
- mount -t unionfs -o dirs=/cow:/rootfs-tmp=ro unionfs $ROOT_MOUNT
- boot_live_root
- fi
+ if ! $MOUNT -o rw,loop,noatime,nodiratime /media/$i/$ISOLINUX/$ROOT_IMAGE $ROOT_MOUNT ; then
+ fatal "Could not mount rootfs image"
else
- if ! $MOUNT -o rw,loop,noatime,nodiratime /media/$i/$ISOLINUX/$ROOT_IMAGE $ROOT_MOUNT ; then
- fatal "Could not mount rootfs image"
- else
- boot_live_root
- fi
+ boot_live_root
fi
;;
install|install-efi)
diff --git a/meta/recipes-core/initrdscripts/initramfs-live-boot_1.0.bb b/meta/recipes-core/initrdscripts/initramfs-live-boot_1.0.bb
index 0cbfe0288b..8626bb5b33 100644
--- a/meta/recipes-core/initrdscripts/initramfs-live-boot_1.0.bb
+++ b/meta/recipes-core/initrdscripts/initramfs-live-boot_1.0.bb
@@ -7,13 +7,6 @@ SRC_URI = "file://init-live.sh"
PR = "r11"
-do_compile() {
- #if grep -q "CONFIG_UNION_FS=y" ${STAGING_KERNEL_DIR}/.config; then
- # sed -i 's/UNIONFS="no"/UNIONFS="yes"/g' ${WORKDIR}/init-live.sh
- #fi
- :
-}
-
do_install() {
install -m 0755 ${WORKDIR}/init-live.sh ${D}/init
}