summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-04 17:43:26 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-04 18:03:13 +0100
commit5dd4de086d744c81d2275077ad0e0022204b0a68 (patch)
tree6ec64251dbcabb7098fcfd5157b800fb8ebc5490 /meta/recipes-core/packagegroups/packagegroup-core-boot.bb
parentc65f8af02ebba371f96119baef0520c6685c7167 (diff)
downloadopenembedded-core-contrib-5dd4de086d744c81d2275077ad0e0022204b0a68.tar.gz
packagegroup-*: add RREPLACES/RCONFLICTS
These are needed to support upgrading from task-* to packagegroup-* within existing target images at runtime. Note: these settings will very likely be moved out to a separate inc file at some point in the future. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/packagegroups/packagegroup-core-boot.bb')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-boot.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-boot.bb b/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
index d29dc2befe..16ad4e3ef8 100644
--- a/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
@@ -6,7 +6,7 @@ SUMMARY = "Minimal boot requirements"
DESCRIPTION = "The minimal set of packages required to boot the system"
LICENSE = "MIT"
DEPENDS = "virtual/kernel"
-PR = "r9"
+PR = "r10"
inherit packagegroup
@@ -20,6 +20,8 @@ MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
# For backwards compatibility after rename
RPROVIDES_${PN} = "task-core-boot"
+RREPLACES_${PN} = "task-core-boot"
+RCONFLICTS_${PN} = "task-core-boot"
# Distro can override the following VIRTUAL-RUNTIME providers:
VIRTUAL-RUNTIME_dev_manager ?= "udev"