summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-04 17:43:26 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-04 18:03:13 +0100
commit5dd4de086d744c81d2275077ad0e0022204b0a68 (patch)
tree6ec64251dbcabb7098fcfd5157b800fb8ebc5490 /meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
parentc65f8af02ebba371f96119baef0520c6685c7167 (diff)
downloadopenembedded-core-contrib-5dd4de086d744c81d2275077ad0e0022204b0a68.tar.gz
packagegroup-*: add RREPLACES/RCONFLICTS
These are needed to support upgrading from task-* to packagegroup-* within existing target images at runtime. Note: these settings will very likely be moved out to a separate inc file at some point in the future. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb b/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
index 931984eb17..103503645d 100644
--- a/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
@@ -5,12 +5,16 @@
SUMMARY = "Profiling tools"
LICENSE = "MIT"
+PR = "r1"
+
inherit packagegroup
PACKAGE_ARCH = "${MACHINE_ARCH}"
# For backwards compatibility after rename
RPROVIDES_${PN} = "task-core-tools-profile"
+RREPLACES_${PN} = "task-core-tools-profile"
+RCONFLICTS_${PN} = "task-core-tools-profile"
RRECOMMENDS_${PN} = "\
perf \