summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/kconfig-frontends
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-09-06 15:20:36 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-10 12:07:44 +0100
commit5857772e285ad6e39b7216bc542189e45f6fdbf7 (patch)
treea99bcffff86cabf45f8dcf7390589d95c8ddbc6d /meta/recipes-devtools/kconfig-frontends
parent13e2ccf6f4e71d674583894750f70865ebe5e4d1 (diff)
downloadopenembedded-core-contrib-5857772e285ad6e39b7216bc542189e45f6fdbf7.tar.gz
kconfig-frontends: Create symlinks for conf and mconf
eglibc calls out mconf and conf directly so lets create symlinks to point to their kconfig- counterparts Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/kconfig-frontends')
-rw-r--r--meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb
index 277de03200..96899b842b 100644
--- a/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb
+++ b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb
@@ -11,7 +11,7 @@ LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408"
SECTION = "devel"
DEPENDS += "ncurses flex bison gperf"
-PR = "r0"
+PR = "r1"
PV = "3.5.0"
SPIN = "0"
SRC_URI = "http://ymorin.is-a-geek.org/download/${BPN}/${BPN}-${PV}-${SPIN}.tar.xz"
@@ -24,6 +24,12 @@ inherit autotools
do_configure_prepend () {
mkdir -p scripts/.autostuff/m4
}
+
+do_install_append() {
+ ln -s kconfig-conf ${D}${bindir}/conf
+ ln -s kconfig-mconf ${D}${bindir}/mconf
+}
+
EXTRA_OECONF += "--disable-gconf --disable-qconf"
# Some packages have the version preceeding the .so instead properly