summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-setuptools_1.4.bb
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2013-11-25 15:50:57 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-26 23:01:51 +0000
commit0d47d440a3674b3eafb605f738e98f82f5698f05 (patch)
treef5cc2f2d86ac504a9a1f113f307bfa117e30bba0 /meta/recipes-devtools/python/python-setuptools_1.4.bb
parentf279a1fc1b6b7e72d8eec782af81cb198ec07e76 (diff)
downloadopenembedded-core-contrib-0d47d440a3674b3eafb605f738e98f82f5698f05.tar.gz
python-setuptools: upgrade to 1.4
Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-setuptools_1.4.bb')
-rw-r--r--meta/recipes-devtools/python/python-setuptools_1.4.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools_1.4.bb b/meta/recipes-devtools/python/python-setuptools_1.4.bb
new file mode 100644
index 0000000000..3cfda56ce6
--- /dev/null
+++ b/meta/recipes-devtools/python/python-setuptools_1.4.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "Download, build, install, upgrade, and uninstall Python packages"
+HOMEPAGE = "http://cheeseshop.python.org/pypi/setuptools"
+SECTION = "devel/python"
+LICENSE = "PSF"
+LIC_FILES_CHKSUM = "file://setup.py;beginline=107;endline=107;md5=8a314270dd7a8dbca741775415f1716e"
+
+SRCNAME = "setuptools"
+DEPENDS += "python"
+DEPENDS_class-native += "python-native"
+
+SRC_URI = "\
+ http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz\
+"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
+
+do_install_prepend() {
+ install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
+}
+
+RDEPENDS_${PN} = "\
+ python-stringold \
+ python-email \
+ python-shell \
+ python-distutils \
+ python-compression \
+"
+
+RDEPENDS_${PN}_class-native = "\
+ python-distutils \
+ python-compression \
+"
+
+SRC_URI[md5sum] = "5710464bc5a61d75f5087f15ce63cfe0"
+SRC_URI[sha256sum] = "75d288687066ed124311d6ca5f40ffa92a0e81adcd7fff318c6e84082713cf39"
+
+BBCLASSEXTEND = "native"