summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/images/core-image-testmaster.bb
diff options
context:
space:
mode:
authorStefan Stanacar <stefanx.stanacar@intel.com>2014-03-30 17:47:34 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-31 17:54:35 +0100
commitdea237ccd9407288cd3a73e1deca270619dd6d4a (patch)
tree2219c29169a4723846e27ab0d09c7b690a86f084 /meta/recipes-extended/images/core-image-testmaster.bb
parent39fcab00cd3b85d40966689e31b4c7748f630739 (diff)
downloadopenembedded-core-contrib-dea237ccd9407288cd3a73e1deca270619dd6d4a.tar.gz
recipes-extended: add master image for testing purposes
Add a custom recipe with custom initramfs and installers, that makes it easy to deploy a master image for testing purposes. We need a master image running on the target hardware, that should be a known good build, with a set of utilities installed so that we use it to deploy the images under test. This core-image-testmaster recipe isn't a requirement per se, any image can be used as long as the required conditions are met. The test code assumes: - that the device has a second rootfs labeled as testrootfs - it has a properly configured bootloader entry (called test) for the second kernel and rootfs - the master image has a /etc/masterimage file so it can differentiate between master and test images - the master image has tar, mount, bash (basically the normal linux utilities not the busybox ones) [YOCTO #5614] Signed-off-by: Stefan Stanacar <stefanx.stanacar@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/images/core-image-testmaster.bb')
-rw-r--r--meta/recipes-extended/images/core-image-testmaster.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-extended/images/core-image-testmaster.bb b/meta/recipes-extended/images/core-image-testmaster.bb
new file mode 100644
index 0000000000..ac2fdbed32
--- /dev/null
+++ b/meta/recipes-extended/images/core-image-testmaster.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "A master image to be deployed on a target useful for testing other images"
+
+IMAGE_FEATURES += "ssh-server-openssh package-management"
+
+inherit core-image
+
+# the deploy code requires bash and
+# normal linux utilities not busybox ones
+IMAGE_INSTALL += "\
+ bash coreutils util-linux tar gzip kmod \
+ python-modules python-misc \
+ e2fsprogs e2fsprogs-mke2fs parted \
+ "
+# we need a particular initramfs for live images
+# that pulls custom install scripts which take
+# care of partitioning for us
+INITRD_IMAGE = "core-image-testmaster-initramfs"
+