summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/rpcsvc-proto/rpcsvc-proto.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-04-27 14:50:18 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-09 10:39:34 +0100
commit290e7111a7b97305715f3db8cc678b9d1cc75726 (patch)
tree056c28f1a46fb9578742a1412912b8a42ce50e54 /meta/recipes-extended/rpcsvc-proto/rpcsvc-proto.bb
parent9dc9983901cec364ea57a72b9da1a0396b60663a (diff)
downloadopenembedded-core-contrib-290e7111a7b97305715f3db8cc678b9d1cc75726.tar.gz
rpcsvc-proto: Add recipe
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-extended/rpcsvc-proto/rpcsvc-proto.bb')
-rw-r--r--meta/recipes-extended/rpcsvc-proto/rpcsvc-proto.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-extended/rpcsvc-proto/rpcsvc-proto.bb b/meta/recipes-extended/rpcsvc-proto/rpcsvc-proto.bb
new file mode 100644
index 0000000000..fdeafe283a
--- /dev/null
+++ b/meta/recipes-extended/rpcsvc-proto/rpcsvc-proto.bb
@@ -0,0 +1,37 @@
+# Copyright (C) 2018 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "rpcsvc protocol definitions from glibc"
+
+DESCRIPTION = "This package contains rpcsvc proto.x files from glibc, which are\
+missing in libtirpc. Additional it contains rpcgen, which is needed\
+to create header files and sources from protocol files.\
+This package is only needed, if glibc is installed without the\
+deprecated sunrpc functionality and libtirpc should replace it."
+
+HOMEPAGE = "https://github.com/thkukuk/rpcsvc-proto"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0daaf958d5531ab86169ec6e275e1517"
+SECTION = "libs"
+DEPENDS += "rpcsvc-proto-native"
+
+PV = "1.3.1+git${SRCPV}"
+
+SRCREV = "abcf24a09665b3def0f54c87d2acd4796de5d83a"
+
+SRC_URI = "git://github.com/thkukuk/${BPN} \
+ file://0001-Use-cross-compiled-rpcgen.patch \
+ "
+
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+EXTRA_OEMAKE_class-native = " -C rpcgen"
+
+do_install_append() {
+ # They come from quota recipe
+ rm -rf ${D}${includedir}/rpcsvc/rquota.[hx]
+}
+
+BBCLASSEXTEND += "native nativesdk"