summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/sed
diff options
context:
space:
mode:
authorMariano Lopez <mariano.lopez@linux.intel.com>2016-08-05 11:25:20 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-10 10:45:13 +0100
commit2ba55933c81f78f4e4c36e21c59e935f74ce0f52 (patch)
tree3f9da5b7d75f56b1ff2ec72b8708702e004c47cc /meta/recipes-extended/sed
parent3a9551479678f97a83db22f213a54169ab4fc989 (diff)
downloadopenembedded-core-contrib-2ba55933c81f78f4e4c36e21c59e935f74ce0f52.tar.gz
quilt/acl/attc/sed: Fix use of tar's --exclude option for tar >= 1.29
Starting from tar 1.29 the --exclude option won't work anymore if is not used before the path. There are some recipes that copy the ptest using tar and --exclude option. This fixes these for OE-Core recipes. [YOCTO #9763] Signed-off-by: Mariano Lopez <mariano.lopez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/sed')
-rw-r--r--meta/recipes-extended/sed/sed-4.2.2/sed-add-ptest.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-extended/sed/sed-4.2.2/sed-add-ptest.patch b/meta/recipes-extended/sed/sed-4.2.2/sed-add-ptest.patch
index 105e8b745b..0293900fbf 100644
--- a/meta/recipes-extended/sed/sed-4.2.2/sed-add-ptest.patch
+++ b/meta/recipes-extended/sed/sed-4.2.2/sed-add-ptest.patch
@@ -54,7 +54,7 @@ index d80e72c..b05f01e 100644
# dummy targets for $(TESTS) so that make does not complain.
+install-ptest:
-+ cd $(BUILDDIR); tar -cf - $(TESTDIR) --exclude *.o | ( cd $(DESTDIR) && tar -xf - )
++ cd $(BUILDDIR); tar -c --exclude=*.o $(TESTDIR) | ( cd $(DESTDIR) && tar -xf - )
+ for i in $(EXTRA_DIST) tst-regex2.c; do install $(srcdir)/$$i $(DESTDIR)/$(TESTDIR); done
+ sed -e 's/^Makefile:/_Makefile:/' -e 's/^srcdir = \(.*\)/srcdir = ./' -e 's/bash/sh/' -i $(DESTDIR)/$(TESTDIR)/Makefile
+ for i in `grep -rl "../sed/sed" $(DESTDIR)/$(TESTDIR)`; do sed -e 's/..\/sed\/sed/sed/' -i $$i; done