summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/freetype/freetype_2.4.3.bb
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@intel.com>2010-11-24 12:20:23 -0800
committerSaul Wold <Saul.Wold@intel.com>2010-11-24 12:50:36 -0800
commitcfb06f9a07b8f0f31f4c5ef82280b1181320f4cc (patch)
tree5058d97b0dd280ec00a2c51ba197cdb30e14ca33 /meta/recipes-graphics/freetype/freetype_2.4.3.bb
parentda7c6441738bfbc6b8d177da7a7c984ad3d6050e (diff)
downloadopenembedded-core-contrib-cfb06f9a07b8f0f31f4c5ef82280b1181320f4cc.tar.gz
freetype: Update to version 2.4.3
Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta/recipes-graphics/freetype/freetype_2.4.3.bb')
-rw-r--r--meta/recipes-graphics/freetype/freetype_2.4.3.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-graphics/freetype/freetype_2.4.3.bb b/meta/recipes-graphics/freetype/freetype_2.4.3.bb
new file mode 100644
index 0000000000..da62ffb3b2
--- /dev/null
+++ b/meta/recipes-graphics/freetype/freetype_2.4.3.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "Freetype font rendering library"
+HOMEPAGE = "http://www.freetype.org/"
+BUGTRACKER = "https://savannah.nongnu.org/bugs/?group=freetype"
+
+LICENSE = "FreeTypeLicense | GPLv2+"
+LIC_FILES_CHKSUM = "file://docs/LICENSE.TXT;md5=8bc1a580aeb518100d00a2dd29e68edf \
+ file://docs/FTL.TXT;md5=d479e83797f699fe873b38dadd0fcd4c \
+ file://docs/GPL.TXT;md5=8ef380476f642c20ebf40fecb0add2ec"
+
+SECTION = "libs"
+
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
+ file://no-hardcode.patch"
+
+S = "${WORKDIR}/freetype-${PV}"
+
+inherit autotools pkgconfig binconfig
+
+LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
+EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
+EXTRA_OEMAKE_virtclass-native = ""
+EXTRA_OECONF = "--without-zlib"
+
+do_configure() {
+ cd builds/unix
+ libtoolize --force --copy
+ aclocal -I .
+ gnu-configize --force
+ autoconf
+ cd ${S}
+ oe_runconf
+}
+
+do_configure_virtclass-native() {
+ (cd builds/unix && gnu-configize) || die "failure running gnu-configize"
+ oe_runconf
+}
+
+do_compile_prepend() {
+ ${BUILD_CC} -o objs/apinames src/tools/apinames.c
+}
+
+FILES_${PN} = "${libdir}/lib*${SOLIBS}"
+FILES_${PN}-dev += "${bindir}"
+
+BBCLASSEXTEND = "native"
+