summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/fstests
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:11 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:57 +0100
commitd62ee7eaf2ba025c3f64b2d4e10dc7cec4637612 (patch)
treef36fe3008f36ff75cbdd31b630f8f13f1f205ebb /meta/recipes-graphics/fstests
parentcaab7fc509bf27706ff3248689f6afd04225cfda (diff)
downloadopenembedded-core-contrib-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.gz
packages: Separate out most of the remaining packages into recipes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-graphics/fstests')
-rw-r--r--meta/recipes-graphics/fstests/fstests_svn.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-graphics/fstests/fstests_svn.bb b/meta/recipes-graphics/fstests/fstests_svn.bb
new file mode 100644
index 0000000000..b4075212ee
--- /dev/null
+++ b/meta/recipes-graphics/fstests/fstests_svn.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Various benchmarning tests for X"
+HOMEPAGE = "http://www.o-hand.com"
+SECTION = "devel"
+LICENSE = "GPL"
+DEPENDS = "pango libxext libxft virtual/libx11 gtk+"
+PV = "0.0+svnr${SRCREV}"
+PR = "r1"
+
+inherit autotools
+
+SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=fstests;proto=http"
+
+S = "${WORKDIR}/fstests/tests"
+
+do_install() {
+ install -d ${D}${bindir}
+ find . -name "test-*" -type f -perm -755 -exec install -m 0755 {} ${D}${bindir} \;
+}