summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mx
diff options
context:
space:
mode:
authorTomas Frydrych <tomas@sleepfive.com>2013-05-20 16:05:24 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-21 09:14:38 +0100
commite49f3e23d7ae7d105d9c32a33bd28590f5c300cd (patch)
tree16c1e5116881eaad9d0d69a98f866d28d3890e62 /meta/recipes-graphics/mx
parent095581d3b888ba702ba0b1b7e9e3ef8fe69dc164 (diff)
downloadopenembedded-core-contrib-e49f3e23d7ae7d105d9c32a33bd28590f5c300cd.tar.gz
mx: Update to improved naming scheme
The package has been renamed to mx-1.0, keeping up with the upstream versioning policy. The 1.14.7 tag does not build with clutter 1.14, so git revision 9b1db6b8060bd00b121a692f942404a24ae2960f from the 1.14 branch is used instead. Signed-off-by: Tomas Frydrych <tomas@sleepfive.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mx')
-rw-r--r--meta/recipes-graphics/mx/mx-1.0_1.4.7.bb14
-rw-r--r--meta/recipes-graphics/mx/mx-1.4/fix-build-dir.patch46
-rw-r--r--meta/recipes-graphics/mx/mx.inc21
-rw-r--r--meta/recipes-graphics/mx/mx/fix-test-includes.patch20
-rw-r--r--meta/recipes-graphics/mx/mx_1.4.7.bb18
5 files changed, 101 insertions, 18 deletions
diff --git a/meta/recipes-graphics/mx/mx-1.0_1.4.7.bb b/meta/recipes-graphics/mx/mx-1.0_1.4.7.bb
new file mode 100644
index 0000000000..4c4c8eb775
--- /dev/null
+++ b/meta/recipes-graphics/mx/mx-1.0_1.4.7.bb
@@ -0,0 +1,14 @@
+require mx.inc
+
+# The 1.4.7 tag does not build against cogl 1.14, pull in a revision with a fix
+SRCREV = "9b1db6b8060bd00b121a692f942404a24ae2960f"
+PV = "1.4.7+git${SRCPV}"
+
+SRC_URI = "git://github.com/clutter-project/mx.git;protocol=git \
+ file://fix-build-dir.patch \
+ file://fix-test-includes.patch \
+ "
+S = "${WORKDIR}/git"
+
+LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=fbc093901857fcd118f065f900982c24 \
+ file://mx/mx-widget.c;beginline=8;endline=20;md5=13bba3c973a72414a701e1e87b5ee879"
diff --git a/meta/recipes-graphics/mx/mx-1.4/fix-build-dir.patch b/meta/recipes-graphics/mx/mx-1.4/fix-build-dir.patch
new file mode 100644
index 0000000000..e7481e9a4b
--- /dev/null
+++ b/meta/recipes-graphics/mx/mx-1.4/fix-build-dir.patch
@@ -0,0 +1,46 @@
+Fix build for S != B
+
+This patch is specific to version 1.4.x
+Upstream-status: Submitted @ https://github.com/clutter-project/mx/issues/81
+Signed-off-by: Tomas Frydrych <tomas@sleepfive.com>
+--
+Index: git/docs/reference/libmx-gtk/Makefile.am
+===================================================================
+--- git.orig/docs/reference/libmx-gtk/Makefile.am 2013-05-08 15:07:02.027154788 +0100
++++ git/docs/reference/libmx-gtk/Makefile.am 2013-05-08 15:14:33.684318650 +0100
+@@ -1,3 +1,6 @@
++EXTRA_DIST=
++CLEANFILES=
++
+ ## Process this file with automake to produce Makefile.in
+
+ # We require automake 1.6 at least.
+@@ -77,7 +80,7 @@
+ GTKDOC_LIBS=$(MX_LIBS) $(top_builddir)/mx-gtk/libmx-gtk-$(MX_API_VERSION).la
+
+ # This includes the standard gtk-doc make rules, copied by gtkdocize.
+-include $(top_srcdir)/gtk-doc.make
++include $(top_builddir)/gtk-doc.make
+
+ # Other files to distribute
+ EXTRA_DIST += version.xml.in
+Index: git/docs/reference/libmx/Makefile.am
+===================================================================
+--- git.orig/docs/reference/libmx/Makefile.am 2013-05-08 15:07:02.027154788 +0100
++++ git/docs/reference/libmx/Makefile.am 2013-05-08 15:14:24.456378135 +0100
+@@ -1,3 +1,6 @@
++EXTRA_DIST=
++CLEANFILES=
++
+ ## Process this file with automake to produce Makefile.in
+
+ # We require automake 1.6 at least.
+@@ -106,7 +109,7 @@
+ GTKDOC_LIBS=$(MX_LIBS) $(top_builddir)/mx/libmx-$(MX_API_VERSION).la
+
+ # This includes the standard gtk-doc make rules, copied by gtkdocize.
+-include $(top_srcdir)/gtk-doc.make
++include $(top_builddir)/gtk-doc.make
+
+ # Other files to distribute
+ EXTRA_DIST += version.xml.in
diff --git a/meta/recipes-graphics/mx/mx.inc b/meta/recipes-graphics/mx/mx.inc
new file mode 100644
index 0000000000..e3b4b15480
--- /dev/null
+++ b/meta/recipes-graphics/mx/mx.inc
@@ -0,0 +1,21 @@
+DESCRIPTION = "Clutter based widget library"
+LICENSE = "LGPLv2.1"
+
+inherit clutter
+
+DEPENDS = "clutter-1.0 dbus-glib gdk-pixbuf"
+
+SRC_URI = "http://source.clutter-project.org/sources/mx/${@get_verdir("${PV}")}/mx-${PV}.tar.xz"
+
+EXTRA_OECONF = "--disable-introspection \
+ --disable-gtk-doc \
+ --disable-gtk-widgets \
+ --with-dbus \
+ --with-winsys=none \
+ --without-clutter-imcontext \
+ --without-clutter-gesture \
+ --without-startup-notification \
+ --without-glade \
+ "
+
+FILES_${PN} += "${datadir}"
diff --git a/meta/recipes-graphics/mx/mx/fix-test-includes.patch b/meta/recipes-graphics/mx/mx/fix-test-includes.patch
new file mode 100644
index 0000000000..c6496a97af
--- /dev/null
+++ b/meta/recipes-graphics/mx/mx/fix-test-includes.patch
@@ -0,0 +1,20 @@
+Fix missing include directory when building tests
+
+This patch is currently required for all versions of mx
+Upstream-status: Submitted @ https://github.com/clutter-project/mx/issues/82
+Signed-off-by: Tomas Frydrych <tomas@sleepfive.com>
+--
+Index: git/tests/Makefile.am
+===================================================================
+--- git.orig/tests/Makefile.am 2013-05-08 15:18:56.918596425 +0100
++++ git/tests/Makefile.am 2013-05-08 15:23:26.864781401 +0100
+@@ -10,7 +10,8 @@
+
+ INCLUDES = \
+ -I$(top_srcdir) \
+- -I$(top_builddir)
++ -I$(top_builddir)\
++ -I$(top_builddir)/mx
+
+ noinst_PROGRAMS = \
+ test-deform-texture \
diff --git a/meta/recipes-graphics/mx/mx_1.4.7.bb b/meta/recipes-graphics/mx/mx_1.4.7.bb
deleted file mode 100644
index fd9189bcea..0000000000
--- a/meta/recipes-graphics/mx/mx_1.4.7.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-DESCRIPTION = "Clutter based widget library"
-LICENSE = "LGPLv2.1"
-
-LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=fbc093901857fcd118f065f900982c24 \
- file://mx/mx-widget.c;beginline=8;endline=20;md5=13bba3c973a72414a701e1e87b5ee879"
-
-PR = "r0"
-
-DEPENDS = "clutter-1.8 dbus-glib libxrandr gdk-pixbuf startup-notification"
-
-inherit autotools gettext
-
-SRC_URI = "https://github.com/downloads/clutter-project/${BPN}/${BP}.tar.xz"
-
-SRC_URI[md5sum] = "19b1e4918a5ae6d014fc0dab2bb3d0a1"
-SRC_URI[sha256sum] = "1d2930d196717cacbee0ee101cf21d289b8200b5e938823d852b3b4a2f4a0e9d"
-
-EXTRA_OECONF = "--disable-introspection --disable-gtk-widgets --with-dbus"