summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/pango/pango_1.44.6.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-09-04 14:49:46 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-06 14:56:00 +0100
commit3673003485d0effdc036c9164bf7a30621960ea4 (patch)
tree3fd1e4cfa76af91baf030c737da6e75ab643ba0e /meta/recipes-graphics/pango/pango_1.44.6.bb
parentc745185b0c112530d1a3d1c57feea0754d68ebb2 (diff)
downloadopenembedded-core-contrib-3673003485d0effdc036c9164bf7a30621960ea4.tar.gz
pango: 1.44.6 upgrade
Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/pango/pango_1.44.6.bb')
-rw-r--r--meta/recipes-graphics/pango/pango_1.44.6.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-graphics/pango/pango_1.44.6.bb b/meta/recipes-graphics/pango/pango_1.44.6.bb
new file mode 100644
index 0000000000..abe90c28d7
--- /dev/null
+++ b/meta/recipes-graphics/pango/pango_1.44.6.bb
@@ -0,0 +1,45 @@
+SUMMARY = "Framework for layout and rendering of internationalized text"
+DESCRIPTION = "Pango is a library for laying out and rendering of text, \
+with an emphasis on internationalization. Pango can be used anywhere \
+that text layout is needed, though most of the work on Pango so far has \
+been done in the context of the GTK+ widget toolkit. Pango forms the \
+core of text and font handling for GTK+-2.x."
+HOMEPAGE = "http://www.pango.org/"
+BUGTRACKER = "http://bugzilla.gnome.org"
+SECTION = "libs"
+LICENSE = "LGPLv2.0+"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
+
+GNOMEBASEBUILDCLASS = "meson"
+
+inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection
+
+SRC_URI += "file://run-ptest"
+SRC_URI[archive.md5sum] = "db0a3243ba33e02aaa775412f8e5f412"
+SRC_URI[archive.sha256sum] = "3e1e41ba838737e200611ff001e3b304c2ca4cdbba63d200a20db0b0ddc0f86c"
+
+DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi"
+
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \
+ ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
+
+PACKAGECONFIG[x11] = ",,virtual/libx11 libxft"
+PACKAGECONFIG[tests] = "-Dinstall-tests=true, -Dinstall-tests=false"
+
+GTKDOC_MESON_OPTION = "gtk_doc"
+GIR_MESON_OPTION = 'introspection'
+
+LEAD_SONAME = "libpango-1.0*"
+LIBV = "1.8.0"
+
+FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
+FILES_${PN}-dev += "${libdir}/pango/${LIBV}/modules/*.la"
+
+RDEPENDS_${PN}-ptest += "cantarell-fonts"
+RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-en-us"
+
+RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \
+ pango-module-basic-fc pango-module-arabic-lang"
+
+BBCLASSEXTEND = "native nativesdk"