summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2011-06-15 14:52:08 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-15 10:35:22 +0100
commit9ba2e41413348e0e9383d4d0d57a7c23cfd5596f (patch)
treea34413512ba1b938149c9903c59d7b95bc9d5ba7 /meta/recipes-graphics
parent09e7b0535f8f2f287da670aabd1d6db76b90686f (diff)
downloadopenembedded-core-contrib-9ba2e41413348e0e9383d4d0d57a7c23cfd5596f.tar.gz
glproto: Revert "glxproto: make GLX swap event struct match spec"
Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/xorg-proto/glproto/restore_the_old_xGLXBufferSwapComplete.patch53
-rw-r--r--meta/recipes-graphics/xorg-proto/glproto_1.4.13.bb3
2 files changed, 55 insertions, 1 deletions
diff --git a/meta/recipes-graphics/xorg-proto/glproto/restore_the_old_xGLXBufferSwapComplete.patch b/meta/recipes-graphics/xorg-proto/glproto/restore_the_old_xGLXBufferSwapComplete.patch
new file mode 100644
index 0000000000..19f41c9434
--- /dev/null
+++ b/meta/recipes-graphics/xorg-proto/glproto/restore_the_old_xGLXBufferSwapComplete.patch
@@ -0,0 +1,53 @@
+Upstream-Status: Inappropriate [backport from upstream]
+
+In May, people already reported the mesa-dri build issue when upgrading to
+glproto-1.4.13 and dri2proto-2.4:
+http://lists.freedesktop.org/archives/mesa-dev/2011-May/007331.html
+
+The story is: Jesse tried to change the definitions of some structs in
+glproto, dri2proto and mesa-dri, but the change in mesa-dri side was accepted
+and then reverted, see
+http://cgit.freedesktop.org/mesa/mesa/commit/?id=dc4a3edcf9d414d5098618d5d3b79d8dd90adcc3
+
+so in glproto and dri2proto's sides, we have to revert the change, too:
+http://cgit.freedesktop.org/xorg/proto/glproto/commit/?id=7196c9441af941be74180f8e8d4e10a08659b80f
+
+We could remove this patch when upgrading to newer glproto, dri2proto and
+mesa-dri in future.
+
+Wed Jun 15 14:33:14 CST 2011
+Dexuan Cui <dexuan.cui@intel.com>
+
+-------------------------------------------------------
+
+commit 7196c9441af941be74180f8e8d4e10a08659b80f
+Author: Jesse Barnes <jbarnes@virtuousgeek.org>
+Date: Thu May 5 09:21:19 2011 -0700
+
+ Revert "glxproto: make GLX swap event struct match spec"
+
+ This reverts commit f5403828c68af0f12c79c0504df0a4781ca84b2b.
+
+ This broke compatibility with existing code, so revert in favor of a new
+ struct definition instead.
+
+diff --git a/glxproto.h b/glxproto.h
+index dfa0647..0ff44e3 100644
+--- a/glxproto.h
++++ b/glxproto.h
+@@ -1375,13 +1375,13 @@ typedef struct {
+ BYTE pad;
+ CARD16 sequenceNumber B16;
+ CARD16 event_type B16;
+- CARD16 pad2;
+ CARD32 drawable;
+ CARD32 ust_hi B32;
+ CARD32 ust_lo B32;
+ CARD32 msc_hi B32;
+ CARD32 msc_lo B32;
+- CARD32 sbc B32;
++ CARD32 sbc_hi B32;
++ CARD32 sbc_lo B32;
+ } xGLXBufferSwapComplete;
+
+ /************************************************************************/
diff --git a/meta/recipes-graphics/xorg-proto/glproto_1.4.13.bb b/meta/recipes-graphics/xorg-proto/glproto_1.4.13.bb
index 38b17b6ad3..7ba9831016 100644
--- a/meta/recipes-graphics/xorg-proto/glproto_1.4.13.bb
+++ b/meta/recipes-graphics/xorg-proto/glproto_1.4.13.bb
@@ -1,4 +1,5 @@
require xorg-proto-common.inc
+SRC_URI += "file://restore_the_old_xGLXBufferSwapComplete.patch"
SUMMARY = "OpenGL: X OpenGL extension headers"
@@ -10,7 +11,7 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=d44ed0146997856304dfbb512a59a8de \
file://glxproto.h;beginline=4;endline=32;md5=6b79c570f644363b356456e7d44471d9"
-PR = "r0"
+PR = "r1"
PE = "1"
BBCLASSEXTEND = "nativesdk"