summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-08-20 12:21:27 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-23 23:01:34 +0100
commit835bb10d07d1a64119379e9837dd853dacfe79bc (patch)
tree8014c80b0520c5d9dfb654ba2c27259859652d55 /meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb
parentbb8cada68e70b1246a76046a37ba57a3ca7aedde (diff)
downloadopenembedded-core-contrib-835bb10d07d1a64119379e9837dd853dacfe79bc.tar.gz
linux-yocto/3.14: add ARM kprobes support
Adding the following commits to the 3.14 tree for ARM kprobe support: c1750e55eb75 ARM: add uprobes support 33e8a1334afe ARM: Make arch_specific_insn a define for new arch_probes_insn structure b1d3feead083 ARM: Add an emulate flag to the kprobes/uprobes instruction decode functions 84b5b70a01a2 ARM: Change the remaining shared kprobes/uprobes symbols to something generic 624e5e9aab5a ARM: Rename the shared kprobes/uprobe return value enum 7741eac39c2e ARM: Change more ARM kprobes symbol names to something more generic 47f51bac6a2d ARM: Make the kprobes condition_check symbol names more generic 3af2f454bb8e ARM: Remove use of struct kprobe from generic probes code a31964d3143a ARM: use a function table for determining instruction interpreter action 6de77767abfc ARM: move generic thumb instruction parsing code to new files for use by other feature eb2db188b856 ARM: Move generic arm instruction parsing code to new files for sharing between features bbc0a43ff46e ARM: move shared uprobe/kprobe definitions into new include file f5f2896020e6 uprobes: allow ignoring of probe hits cb133db6bd60 ARM: Fix missing includes in kprobes sources Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb
index 78209b1070..4a91638c55 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb
@@ -3,8 +3,8 @@ require recipes-kernel/linux/linux-yocto.inc
KBRANCH = "standard/preempt-rt/base"
KBRANCH_qemuppc = "standard/preempt-rt/qemuppc"
-SRCREV_machine ?= "8ef1733b66a1646b85338a310f787e0057a6a4e9"
-SRCREV_machine_qemuppc ?= "3079c794c30b0de82bc87b19cf477d82405a9094"
+SRCREV_machine ?= "9e6a44f2c638dc94692a8094eda3919cbc53cdb7"
+SRCREV_machine_qemuppc ?= "04464fbce3be9894f0752d3fbd5c1bf3fb14ebcf"
SRCREV_meta ?= "54d07ec2566afe2a4c1eee4995781aab5599b5d5"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.14.git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"