summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2010-10-13 22:41:50 -0400
committerRichard Purdie <rpurdie@linux.intel.com>2010-11-10 21:22:27 +0800
commit570cf02a833ea93a0935b68aa01d49ffb2e2c2ff (patch)
treee3363c15b763bdd3a677b1891200ed8b97a20cb9 /meta/recipes-kernel
parentbca56bfcc9a9cf745a5864f000a8af0f0421c1be (diff)
downloadopenembedded-core-contrib-570cf02a833ea93a0935b68aa01d49ffb2e2c2ff.tar.gz
linux-wrs: rename force_revisions and allow override
It is useful to override revision checking from a layer or other recipe. In order to show the global nature of the variable rename it KERNEL_REVISION_CHECKING and make it a weak assignment. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-wrs_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-kernel/linux/linux-wrs_git.bb b/meta/recipes-kernel/linux/linux-wrs_git.bb
index c43ae11226..1f2b11e975 100644
--- a/meta/recipes-kernel/linux/linux-wrs_git.bb
+++ b/meta/recipes-kernel/linux/linux-wrs_git.bb
@@ -34,7 +34,7 @@ S = "${WORKDIR}/linux"
B = "${WORKDIR}/linux-${WRMACHINE}-${LINUX_KERNEL_TYPE}-build"
# functionality flags
-force_revisions = "t"
+KERNEL_REVISION_CHECKING ?= "t"
KERNEL_FEATURES=features/netfilter
do_patch() {
@@ -75,7 +75,7 @@ validate_branches() {
target_meta_head="${SRCREV_meta}"
if [ -n "$target_branch_head" ] && [ "$branch_head" != "$target_branch_head" ]; then
- if [ -n "${force_revisions}" ]; then
+ if [ -n "${KERNEL_REVISION_CHECKING}" ]; then
git show ${target_branch_head} > /dev/null 2>&1
if [ $? -eq 0 ]; then
echo "Forcing branch ${WRMACHINE}-${LINUX_KERNEL_TYPE} to ${target_branch_head}"
@@ -90,7 +90,7 @@ validate_branches() {
fi
if [ "$meta_head" != "$target_meta_head" ]; then
- if [ -n "${force_revisions}" ]; then
+ if [ -n "${KERNEL_REVISION_CHECKING}" ]; then
git show ${target_meta_head} > /dev/null 2>&1
if [ $? -eq 0 ]; then
echo "Forcing branch wrs_meta to ${target_meta_head}"