summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-03-04 11:13:07 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-03-06 08:17:26 +0000
commit8764cc85f3ef570f1c220c3c200d6e02d3e7a260 (patch)
tree7b4ce90a263d0f9f9ebe184c62acb4c75556ce1e /meta/recipes-kernel
parent965090f42bc0576e938a0575b7938a1ff60b0018 (diff)
downloadopenembedded-core-contrib-8764cc85f3ef570f1c220c3c200d6e02d3e7a260.tar.gz
linux-firmware: use 'make install' for installation
Copying the source tree over was missing important symlinks that since recent updates can only be created with make install. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux-firmware/linux-firmware_20200122.bb22
1 files changed, 1 insertions, 21 deletions
diff --git a/meta/recipes-kernel/linux-firmware/linux-firmware_20200122.bb b/meta/recipes-kernel/linux-firmware/linux-firmware_20200122.bb
index 0d1422cfca..f7198cb56a 100644
--- a/meta/recipes-kernel/linux-firmware/linux-firmware_20200122.bb
+++ b/meta/recipes-kernel/linux-firmware/linux-firmware_20200122.bb
@@ -208,27 +208,7 @@ do_compile() {
}
do_install() {
- install -d ${D}${nonarch_base_libdir}/firmware/
- cp -r * ${D}${nonarch_base_libdir}/firmware/
-
- # Avoid Makefile to be deployed
- rm ${D}${nonarch_base_libdir}/firmware/Makefile
-
- # Remove unbuild firmware which needs cmake and bash
- rm ${D}${nonarch_base_libdir}/firmware/carl9170fw -rf
-
- # Remove pointless bash script
- rm ${D}${nonarch_base_libdir}/firmware/configure
-
- # Remove python script used to check the WHENCE file
- rm ${D}${nonarch_base_libdir}/firmware/check_whence.py
-
- # Libertas sd8686
- ln -sf libertas/sd8686_v9.bin ${D}${nonarch_base_libdir}/firmware/sd8686.bin
- ln -sf libertas/sd8686_v9_helper.bin ${D}${nonarch_base_libdir}/firmware/sd8686_helper.bin
-
- # fixup wl12xx location, after 2.6.37 the kernel searches a different location for it
- ( cd ${D}${nonarch_base_libdir}/firmware ; ln -sf ti-connectivity/* . )
+ oe_runmake 'DESTDIR=${D}' install
}