summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2021-11-12 14:02:34 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-11-13 16:08:07 +0000
commitf70f9a7f44676f722e2541e1ef1f064c942fffcb (patch)
tree2a8ea2009cd01ca310173b72ec4948d679f5fbce /meta/recipes-kernel
parentf8f25c424079074b9ed4a7801122c2f59f22aacf (diff)
downloadopenembedded-core-contrib-f70f9a7f44676f722e2541e1ef1f064c942fffcb.tar.gz
dtc: add PACKAGECONFIGs for tools and yaml
Leave yaml off by default. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/dtc/dtc_1.6.1.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta/recipes-kernel/dtc/dtc_1.6.1.bb b/meta/recipes-kernel/dtc/dtc_1.6.1.bb
index 44293cf4ff..6365f73e10 100644
--- a/meta/recipes-kernel/dtc/dtc_1.6.1.bb
+++ b/meta/recipes-kernel/dtc/dtc_1.6.1.bb
@@ -3,7 +3,6 @@ HOMEPAGE = "https://devicetree.org/"
DESCRIPTION = "The Device Tree Compiler is a tool used to manipulate the Open-Firmware-like device tree used by PowerPC kernels."
SECTION = "bootloader"
LICENSE = "GPLv2 | BSD-2-Clause"
-DEPENDS = "flex-native bison-native"
LIC_FILES_CHKSUM = "file://GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
file://libfdt/libfdt.h;beginline=4;endline=7;md5=05bb357cfb75cae7d2b01d2ee8d76407"
@@ -19,9 +18,12 @@ inherit meson pkgconfig
EXTRA_OEMESON = "-Dpython=disabled -Dvalgrind=disabled"
+PACKAGECONFIG ??= "tools"
+PACKAGECONFIG[tools] = "-Dtools=true,-Dtools=false,flex-native bison-native"
+PACKAGECONFIG[yaml] = "-Dyaml=enabled,-Dyaml=disabled,libyaml"
+
PACKAGES =+ "${PN}-misc"
FILES:${PN}-misc = "${bindir}/convert-dtsv0 ${bindir}/ftdump ${bindir}/dtdiff"
-
-RDEPENDS:${PN}-misc += "bash diffutils"
+RDEPENDS:${PN}-misc += "${@bb.utils.contains('PACKAGECONFIG', 'tools', 'bash diffutils', '', d)}"
BBCLASSEXTEND = "native nativesdk"