summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/alsa
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2011-07-14 15:40:36 +0800
committerSaul Wold <sgw@linux.intel.com>2011-07-20 01:17:45 -0700
commit81e92e8eab7f0f3d4ca72d4c7d1b872ebdc82fc8 (patch)
tree23f0ae3b45ca69600f3f4d4aeab2573d07537a9b /meta/recipes-multimedia/alsa
parent6ca80453618fa308cc2d6329450aaf5dfdf2d610 (diff)
downloadopenembedded-core-contrib-81e92e8eab7f0f3d4ca72d4c7d1b872ebdc82fc8.tar.gz
alsa-tools: Fix recipe build error.
Remove some elements in alsa-tools to avoid build error and further dependency on new recipes. [YOCTO #1038] Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Diffstat (limited to 'meta/recipes-multimedia/alsa')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-tools-1.0.24.1/autotools.patch34
-rw-r--r--meta/recipes-multimedia/alsa/alsa-tools_1.0.24.1.bb7
2 files changed, 39 insertions, 2 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-tools-1.0.24.1/autotools.patch b/meta/recipes-multimedia/alsa/alsa-tools-1.0.24.1/autotools.patch
new file mode 100644
index 0000000000..c7bc2d6bd0
--- /dev/null
+++ b/meta/recipes-multimedia/alsa/alsa-tools-1.0.24.1/autotools.patch
@@ -0,0 +1,34 @@
+Add parameters to autoreconf to support cross compile.
+Remove some sub-components which needs further recipe support.
+
+Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
+
+Upstream-Status: Inappropriate [configuration]
+
+diff -ruN alsa-tools-1.0.24.1-orig//ld10k1/gitcompile alsa-tools-1.0.24.1/ld10k1/gitcompile
+--- alsa-tools-1.0.24.1-orig//ld10k1/gitcompile 2011-07-06 11:27:40.227665002 +0800
++++ alsa-tools-1.0.24.1/ld10k1/gitcompile 2011-07-14 13:26:18.017665004 +0800
+@@ -1,6 +1,6 @@
+ #!/bin/bash
+
+-autoreconf -fi || exit 1
++autoreconf $ACLOCAL_FLAGS -fi || exit 1
+ export CFLAGS='-O2 -Wall -pipe -g'
+ echo "CFLAGS=$CFLAGS"
+ echo "./configure $@"
+diff -ruN alsa-tools-1.0.24.1-orig//Makefile alsa-tools-1.0.24.1/Makefile
+--- alsa-tools-1.0.24.1-orig//Makefile 2011-07-06 11:27:40.207665000 +0800
++++ alsa-tools-1.0.24.1/Makefile 2011-07-14 15:08:08.877665009 +0800
+@@ -1,9 +1,8 @@
+ VERSION = 1.0.24.1
+ TOP = .
+-SUBDIRS = ac3dec as10k1 envy24control hdsploader hdspconf hdspmixer \
+- mixartloader pcxhrloader rmedigicontrol sb16_csp seq sscape_ctl \
+- us428control usx2yloader vxloader echomixer ld10k1 qlo10k1 \
+- hwmixvolume
++SUBDIRS = ac3dec as10k1 hdsploader mixartloader pcxhrloader sb16_csp \
++ seq sscape_ctl us428control usx2yloader vxloader ld10k1 \
++ hwmixvolume
+
+ all:
+ @for i in $(SUBDIRS); do \
diff --git a/meta/recipes-multimedia/alsa/alsa-tools_1.0.24.1.bb b/meta/recipes-multimedia/alsa/alsa-tools_1.0.24.1.bb
index 5b3ea981d3..1bf9cd099a 100644
--- a/meta/recipes-multimedia/alsa/alsa-tools_1.0.24.1.bb
+++ b/meta/recipes-multimedia/alsa/alsa-tools_1.0.24.1.bb
@@ -5,13 +5,16 @@ SECTION = "console/utils"
LICENSE = "GPLv2"
DEPENDS = "alsa-lib ncurses"
-PR = "r1"
+PR = "r2"
LIC_FILES_CHKSUM = "file://hdsploader/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-SRC_URI = "ftp://ftp.alsa-project.org/pub/tools/alsa-tools-${PV}.tar.bz2"
+SRC_URI = "ftp://ftp.alsa-project.org/pub/tools/alsa-tools-${PV}.tar.bz2 \
+ file://autotools.patch"
SRC_URI[md5sum] = "08fe93a12006093e590d7ecc02b119dd"
SRC_URI[sha256sum] = "17d43de93ab2db98886d89a53e45341daa46a4ef6edd405db87f4b5a5dc64a05"
inherit autotools
+
+EXTRA_OEMAKE += "GITCOMPILE_ARGS='--host=${HOST_SYS} --build=${BUILD_SYS} --target=${TARGET_SYS} --with-libtool-sysroot=${STAGING_DIR_HOST}' ACLOCAL_FLAGS='-I ${STAGING_DATADIR}/aclocal'"