summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.18.0.bb
diff options
context:
space:
mode:
authorJose Quaresma <quaresma.jose@gmail.com>2020-10-29 14:27:56 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-10-31 08:53:13 +0000
commit1d2b86327e63f091e8e677b6c853948d7a00fc8a (patch)
treee78983ebd12af41fca61a6ac4806b3796801aba1 /meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.18.0.bb
parent62c670c7708c0a4b666a71d40af50f6d6cf8dc1a (diff)
downloadopenembedded-core-contrib-1d2b86327e63f091e8e677b6c853948d7a00fc8a.tar.gz
gstreamer1.0-python: upgrade to version 1.18.0
* 0001-meson.build-fix-builds-with-python-3.8.patch Removed since these are included in 1.18.0 DEPENDS: RDEPENDS: - Upstream now depends gstreamer1.0-plugins-base Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.18.0.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.18.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.18.0.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.18.0.bb
new file mode 100644
index 0000000000..f13f9c5a44
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.18.0.bb
@@ -0,0 +1,35 @@
+SUMMARY = "Python bindings for GStreamer 1.0"
+HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/"
+SECTION = "multimedia"
+
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740"
+
+SRC_URI = "https://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz"
+SRC_URI[md5sum] = "2d55c22fcd57cae4fad55a07019aa334"
+SRC_URI[sha256sum] = "76bfe8b85a9c4a6ddfb81874f2635fd0da38c3f39d9d2a0b175213218516dd45"
+
+DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject"
+RDEPENDS_${PN} += "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject"
+
+PNREAL = "gst-python"
+
+S = "${WORKDIR}/${PNREAL}-${PV}"
+
+# gobject-introspection is mandatory and cannot be configured
+REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
+UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"
+
+inherit meson pkgconfig distutils3-base upstream-version-is-even gobject-introspection features_check
+
+do_install_append() {
+
+ # Note that this particular find line is taken from the Debian packaging for
+ # gst-python1.0.
+ find "${D}" \
+ -name '*.pyc' -o \
+ -name '*.pyo' -o \
+ -name '*.la' -o \
+ -name 'libgstpythonplugin*' \
+ -delete
+}