summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/tasks
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-09-20 14:18:45 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-20 14:18:45 +0100
commit79a4501a2ead92cb512eef0bd3dfe133d0e5d799 (patch)
tree5f82f1971c81034799bd5ab330e54b281020fc24 /meta/recipes-sato/tasks
parent03d9669cbcc35a49120b9cc277723bccd93f4cf3 (diff)
downloadopenembedded-core-contrib-79a4501a2ead92cb512eef0bd3dfe133d0e5d799.tar.gz
Complete packages -> recipes transition
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-sato/tasks')
-rw-r--r--meta/recipes-sato/tasks/task-poky.bb72
1 files changed, 72 insertions, 0 deletions
diff --git a/meta/recipes-sato/tasks/task-poky.bb b/meta/recipes-sato/tasks/task-poky.bb
new file mode 100644
index 0000000000..1f971954cd
--- /dev/null
+++ b/meta/recipes-sato/tasks/task-poky.bb
@@ -0,0 +1,72 @@
+#
+# Copyright (C) 2007-2008 OpenedHand Ltd.
+#
+
+DESCRIPTION = "Tasks for OpenedHand Poky"
+LICENSE = "MIT"
+PR = "r33"
+
+PACKAGES = "\
+ task-poky-apps-console \
+ task-poky-apps-console-dbg \
+ task-poky-apps-console-dev \
+ task-poky-apps-x11-core \
+ task-poky-apps-x11-core-dbg \
+ task-poky-apps-x11-core-dev \
+ task-poky-apps-x11-games \
+ task-poky-apps-x11-games-dbg \
+ task-poky-apps-x11-games-dev \
+ task-poky-x11-base \
+ task-poky-x11-base-dbg \
+ task-poky-x11-base-dev \
+ "
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+XSERVER ?= "xserver-kdrive-fbdev"
+
+ALLOW_EMPTY = "1"
+
+SPLASH ?= "psplash"
+
+# pcmanfm doesn't work on mips/powerpc
+FILEMANAGER ?= "pcmanfm"
+FILEMANAGER_mips ?= ""
+
+RDEPENDS_task-poky-apps-console = "\
+ avahi-daemon \
+ dropbear \
+ dbus \
+ portmap \
+ ${SPLASH}"
+
+
+RDEPENDS_task-poky-x11-base = "\
+ dbus \
+ pointercal \
+ matchbox-wm \
+ matchbox-keyboard \
+ matchbox-keyboard-applet \
+ matchbox-keyboard-im \
+ matchbox-panel-2 \
+ matchbox-desktop \
+ matchbox-session \
+ ${XSERVER} \
+ x11-common \
+ xserver-nodm-init \
+ liberation-fonts \
+ xauth \
+ xhost \
+ xset \
+ xrandr"
+
+
+RDEPENDS_task-poky-apps-x11-core = "\
+ leafpad \
+ ${FILEMANAGER} \
+ matchbox-terminal \
+ screenshot"
+
+
+RDEPENDS_task-poky-apps-x11-games = "\
+ oh-puzzles"