summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-07-18 15:50:59 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-20 15:25:01 +0100
commit3c6661680822246658ea47394ef1673fc068551c (patch)
tree6ccf709f09f14af7db3074469b51d7b49654588b /meta
parentc480def3a3531577659a9cc0f10640f3df047bc2 (diff)
downloadopenembedded-core-contrib-3c6661680822246658ea47394ef1673fc068551c.tar.gz
oprofile: Fix build when query_module is not there
on 2.6 kernels we do not have query_module so warn about it Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-kernel/oprofile/oprofile/oprofile-no-query-modules.patch29
-rw-r--r--meta/recipes-kernel/oprofile/oprofile_0.9.6.bb3
2 files changed, 31 insertions, 1 deletions
diff --git a/meta/recipes-kernel/oprofile/oprofile/oprofile-no-query-modules.patch b/meta/recipes-kernel/oprofile/oprofile/oprofile-no-query-modules.patch
new file mode 100644
index 0000000000..c9d7cd63e7
--- /dev/null
+++ b/meta/recipes-kernel/oprofile/oprofile/oprofile-no-query-modules.patch
@@ -0,0 +1,29 @@
+disable portions which use query_module on 2.6 kernel this is not available
+in OE we dont support 2.4 anyway
+
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Index: oprofile-0.9.6/daemon/liblegacy/opd_kernel.c
+===================================================================
+--- oprofile-0.9.6.orig/daemon/liblegacy/opd_kernel.c 2009-11-24 07:25:17.000000000 -0800
++++ oprofile-0.9.6/daemon/liblegacy/opd_kernel.c 2011-07-18 10:08:39.863798825 -0700
+@@ -270,6 +270,9 @@
+ */
+ static void opd_drop_module_sample(unsigned long eip)
+ {
++ verbprintf(vmodule, "query_module not available on linux-2.6: %s\n", strerror(EPERM));
++
++#if 0
+ char * module_names;
+ char * name;
+ size_t size = 1024;
+@@ -307,6 +310,7 @@
+
+ if (module_names)
+ free(module_names);
++#endif
+ }
+
+
diff --git a/meta/recipes-kernel/oprofile/oprofile_0.9.6.bb b/meta/recipes-kernel/oprofile/oprofile_0.9.6.bb
index 603500d428..0f154c8cec 100644
--- a/meta/recipes-kernel/oprofile/oprofile_0.9.6.bb
+++ b/meta/recipes-kernel/oprofile/oprofile_0.9.6.bb
@@ -19,10 +19,11 @@ FILES_${PN} = "${bindir} ${libdir}/${BPN}/lib*.so.* ${datadir}/${BPN}"
FILES_${PN}-dev += "${libdir}/${BPN}/lib*.so ${libdir}/${BPN}/lib*.la"
FILES_${PN}-staticdev += "${libdir}/${BPN}/lib*.a"
-PR = "r1"
+PR = "r2"
SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
file://opstart.patch \
+ file://oprofile-no-query-modules.patch \
file://acinclude.m4"
SRC_URI[md5sum] = "4e407093ac06200185d5a5e6437d7242"