summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2010-11-18 16:20:48 -0500
committerSaul Wold <Saul.Wold@intel.com>2010-12-10 22:01:37 -0800
commit48d00ad8d5134b5bf3215df4faca7c7fd01154eb (patch)
tree2ab77e65c97f125460f0e6c548c40b8f2b973b2e /meta
parent0e7d9956a0cbe95cfe2919d13fcfcac705c4b104 (diff)
downloadopenembedded-core-contrib-48d00ad8d5134b5bf3215df4faca7c7fd01154eb.tar.gz
linux-libc-headers-yocto: use common linux-yocto routines
Modify linux-libc-headers-yocto to use the common linux-yocto routines, so headers exported to userspace will track the branches in the yocto kernel git repository. This commit also switches supported boards to prefer the yocto libc headers. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb21
1 files changed, 9 insertions, 12 deletions
diff --git a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
index 3e3c1fa9ba..0515233958 100644
--- a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
+++ b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
@@ -1,4 +1,7 @@
require linux-libc-headers.inc
+include recipes-kernel/linux/linux-yocto.inc
+
+B = "${S}"
INHIBIT_DEFAULT_DEPS = "1"
DEPENDS += "unifdef-native"
@@ -8,7 +11,9 @@ PR = "r1"
SRC_URI = "git://git.pokylinux.org/linux-2.6-windriver.git;fullclone=1"
-S = "${WORKDIR}/linux"
+SRCREV_FORMAT = "meta_machine"
+SRC_URI = "git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;fullclone=1;branch=${KBRANCH};name=machine \
+ git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;noclone=1;branch=wrs_meta;name=meta"
set_arch() {
case ${TARGET_ARCH} in
@@ -26,19 +31,11 @@ do_configure() {
oe_runmake allnoconfig ARCH=$ARCH
}
-do_kernel_checkout() {
- if [ -d ${WORKDIR}/.git/refs/remotes/origin ]; then
- rm -rf ${S}
- mkdir ${S}
- mv ${WORKDIR}/.git ${S}
- mv ${S}/.git/refs/remotes/origin/* ${S}/.git/refs/heads
- rmdir ${S}/.git/refs/remotes/origin
- fi
- cd ${S}
- git checkout -f standard
+do_kernel_configme() {
}
-addtask kernel_checkout before do_patch after do_unpack
+do_patch () {
+}
do_compile () {
}