summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-12-25 19:43:59 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-31 09:42:49 +0000
commit4c2434271cfc41e910969266ced9e5f06ee0c732 (patch)
tree86334d0dd14cac52957c831a00b82bb473b5962f /meta
parent87be2314fe0e67a616b4f713106b4ae46931f5cb (diff)
downloadopenembedded-core-contrib-4c2434271cfc41e910969266ced9e5f06ee0c732.tar.gz
xf86-video-omap: skip package if opengl isn't in DISTRO_FEATURES
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-graphics/xorg-driver/xf86-video-omap_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-driver/xf86-video-omap_git.bb b/meta/recipes-graphics/xorg-driver/xf86-video-omap_git.bb
index dea8ca28a0..f74419f94f 100644
--- a/meta/recipes-graphics/xorg-driver/xf86-video-omap_git.bb
+++ b/meta/recipes-graphics/xorg-driver/xf86-video-omap_git.bb
@@ -40,3 +40,9 @@ CFLAGS += " -I${STAGING_INCDIR}/xorg "
do_compile_prepend_armv7a () {
sed -i -e s:fb1:fb2:g ${S}/src/omap_xv.c
}
+
+python () {
+ if not oe.utils.contains ('DISTRO_FEATURES', 'opengl', True, False, d):
+ raise bb.parse.SkipPackage("'opengl' not in DISTRO_FEATURES")
+}
+