summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2010-09-01 11:18:15 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-02 09:50:50 +0100
commitc4ecd356d17e243655dd580b0636be1fe6ad4e77 (patch)
treece09af1741b76149b438e58698c4cb7443f3520f /meta
parent8232e014379dcb51938b5328c30630997da05f38 (diff)
downloadopenembedded-core-contrib-c4ecd356d17e243655dd580b0636be1fe6ad4e77.tar.gz
sed: Upgraded to the latest version 4.2.1
sed version 4.2.1 is under GPLv3 license inherit update-altenatives to handle the install priority issue Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-extended/sed/sed_4.2.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-extended/sed/sed_4.2.1.bb b/meta/recipes-extended/sed/sed_4.2.1.bb
new file mode 100644
index 0000000000..5147b0d12e
--- /dev/null
+++ b/meta/recipes-extended/sed/sed_4.2.1.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "sed is a Stream EDitor."
+HOMEPAGE = "http://www.gnu.org/software/sed/"
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949 \
+ file://sed/sed.h;beginline=1;endline=17;md5=767ab3a06d7584f6fd0469abaec4412f"
+SECTION = "console/utils"
+PR = "r0"
+
+DEPENDS = "gettext"
+
+SRC_URI = "${GNU_MIRROR}/sed/sed-${PV}.tar.gz"
+
+inherit autotools update-alternatives
+
+do_install () {
+ autotools_do_install
+ install -d ${D}${base_bindir}
+ mv ${D}${bindir}/sed ${D}${base_bindir}/sed.${PN}
+}
+
+ALTERNATIVE_NAME = "sed"
+ALTERNATIVE_PATH = "sed.${PN}"
+ALTERNATIVE_PRIORITY = "100"
+
+BBCLASSEXTEND = "native"