summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd/0004-configure-Check-for-additional-features-that-uclibc-.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/systemd/systemd/0004-configure-Check-for-additional-features-that-uclibc-.patch')
-rw-r--r--meta/recipes-core/systemd/systemd/0004-configure-Check-for-additional-features-that-uclibc-.patch23
1 files changed, 10 insertions, 13 deletions
diff --git a/meta/recipes-core/systemd/systemd/0004-configure-Check-for-additional-features-that-uclibc-.patch b/meta/recipes-core/systemd/systemd/0004-configure-Check-for-additional-features-that-uclibc-.patch
index dddb7da690..8078da9bb4 100644
--- a/meta/recipes-core/systemd/systemd/0004-configure-Check-for-additional-features-that-uclibc-.patch
+++ b/meta/recipes-core/systemd/systemd/0004-configure-Check-for-additional-features-that-uclibc-.patch
@@ -14,13 +14,13 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
configure.ac | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)
-diff --git a/configure.ac b/configure.ac
-index 9a2235b..a5b2e6e 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -103,6 +103,24 @@ AS_IF([! ln --relative --help > /dev/null 2>&1], [AC_MSG_ERROR([*** ln doesn't s
+Index: git/configure.ac
+===================================================================
+--- git.orig/configure.ac
++++ git/configure.ac
+@@ -110,6 +110,24 @@ AC_PATH_PROG([UMOUNT_PATH], [umount], [/
- M4_DEFINES=
+ AS_IF([! ln --relative --help > /dev/null 2>&1], [AC_MSG_ERROR([*** ln doesn't support --relative ***])])
+# check for few functions not implemented in uClibc
+
@@ -31,7 +31,7 @@ index 9a2235b..a5b2e6e 100644
+AC_MSG_CHECKING([whether %ms format is supported by *scanf])
+
+AC_LINK_IFELSE(
-+ [AC_LANG_PROGRAM([
++ [AC_LANG_PROGRAM([
+ #include <stdio.h>
+ ],[
+ char *buf1, *buf2, *buf3, str="1 2.3 abcde" ;
@@ -40,9 +40,6 @@ index 9a2235b..a5b2e6e 100644
+ [AC_DEFINE([HAVE_MSFORMAT], [1], [Define if %ms format is supported by *scanf.])],
+ [AC_MSG_RESULT([no])])
+
- # gtkdocize greps for '^GTK_DOC_CHECK', so it needs to be on its own line
- m4_ifdef([GTK_DOC_CHECK], [
- GTK_DOC_CHECK([1.18],[--flavour no-tmpl])],
---
-2.1.4
-
+ M4_DEFINES=
+
+ AC_CHECK_TOOL(OBJCOPY, objcopy)