summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-native_2.6.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-native_2.6.6.bb')
-rw-r--r--meta/recipes-devtools/python/python-native_2.6.6.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.6.6.bb b/meta/recipes-devtools/python/python-native_2.6.6.bb
index fa943f4633..59ed61a67a 100644
--- a/meta/recipes-devtools/python/python-native_2.6.6.bb
+++ b/meta/recipes-devtools/python/python-native_2.6.6.bb
@@ -36,4 +36,9 @@ do_install() {
oe_runmake 'DESTDIR=${D}' install
install -d ${D}${bindir}/
install -m 0755 Parser/pgen ${D}${bindir}/
+
+ # Make sure we use /usr/bin/env python
+ for PYTHSCRIPT in `grep -rIl ${bindir}/python ${D}${bindir}`; do
+ sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT
+ done
}