summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2021-08-03 21:28:04 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-04 20:41:45 +0100
commit22f9c7268b542baf6cd8aa0e34c8fb7aa1579e08 (patch)
tree5d712d30c7a3e10bd90de5f0ab24895c0c2891a4
parent2b8fce67d687729b62c237fe46f9a0758a324dd1 (diff)
downloadopenembedded-core-22f9c7268b542baf6cd8aa0e34c8fb7aa1579e08.tar.gz
meta: convert nested overrides leftovers to new syntax
Those were missed in previous rounds of automated and manual conversion. Signed-off-by: Denys Dmytriyenko <denis@denix.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/classes/manpages.bbclass4
-rw-r--r--meta/recipes-devtools/gcc/gcc-configure-common.inc2
-rw-r--r--meta/recipes-devtools/gcc/gcc-cross-canadian.inc8
-rw-r--r--meta/recipes-devtools/gcc/gcc-runtime.inc2
-rw-r--r--meta/recipes-devtools/gdb/gdb-common.inc8
-rw-r--r--meta/recipes-kernel/perf/perf.bb2
6 files changed, 13 insertions, 13 deletions
diff --git a/meta/classes/manpages.bbclass b/meta/classes/manpages.bbclass
index 3a96659460..64b7d8c422 100644
--- a/meta/classes/manpages.bbclass
+++ b/meta/classes/manpages.bbclass
@@ -12,7 +12,7 @@ MAN_PKG ?= "${PN}-doc"
# only add man-db to RDEPENDS when manual files are built and installed
RDEPENDS:${MAN_PKG} += "${@bb.utils.contains('PACKAGECONFIG', 'manpages', 'man-db', '', d)}"
-pkg_postinst:append_${MAN_PKG} () {
+pkg_postinst:append:${MAN_PKG} () {
# only update manual page index caches when manual files are built and installed
if ${@bb.utils.contains('PACKAGECONFIG', 'manpages', 'true', 'false', d)}; then
if test -n "$D"; then
@@ -36,7 +36,7 @@ pkg_postinst:append_${MAN_PKG} () {
fi
}
-pkg_postrm:append_${MAN_PKG} () {
+pkg_postrm:append:${MAN_PKG} () {
# only update manual page index caches when manual files are built and installed
if ${@bb.utils.contains('PACKAGECONFIG', 'manpages', 'true', 'false', d)}; then
mandb -q
diff --git a/meta/recipes-devtools/gcc/gcc-configure-common.inc b/meta/recipes-devtools/gcc/gcc-configure-common.inc
index e9bc8e466c..e4cdb73f0a 100644
--- a/meta/recipes-devtools/gcc/gcc-configure-common.inc
+++ b/meta/recipes-devtools/gcc/gcc-configure-common.inc
@@ -56,7 +56,7 @@ export gcc_cv_collect2_libs = 'none required'
# in the config.log files (which might not get generated until do_compile
# hence being missed by the insane do_configure check).
-EXTRA_OECONF:append_linux = " --enable-__cxa_atexit"
+EXTRA_OECONF:append:linux = " --enable-__cxa_atexit"
EXTRA_OECONF:append:mips64 = " --with-abi=64 --with-arch-64=mips64 --with-tune-64=mips64"
EXTRA_OECONF:append:mips64el = " --with-abi=64 --with-arch-64=mips64 --with-tune-64=mips64"
diff --git a/meta/recipes-devtools/gcc/gcc-cross-canadian.inc b/meta/recipes-devtools/gcc/gcc-cross-canadian.inc
index 92fb1f38ba..495dd9070b 100644
--- a/meta/recipes-devtools/gcc/gcc-cross-canadian.inc
+++ b/meta/recipes-devtools/gcc/gcc-cross-canadian.inc
@@ -180,9 +180,9 @@ SYSTEMLIBS = "${target_base_libdir}/"
SYSTEMLIBS1 = "${target_libdir}/"
EXTRA_OECONF += "--enable-poison-system-directories"
-EXTRA_OECONF:remove_elf = "--with-sysroot=/not/exist"
-EXTRA_OECONF:remove_eabi = "--with-sysroot=/not/exist"
-EXTRA_OECONF:append_elf = " --without-headers --with-newlib"
-EXTRA_OECONF:append_eabi = " --without-headers --with-newlib"
+EXTRA_OECONF:remove:elf = "--with-sysroot=/not/exist"
+EXTRA_OECONF:remove:eabi = "--with-sysroot=/not/exist"
+EXTRA_OECONF:append:elf = " --without-headers --with-newlib"
+EXTRA_OECONF:append:eabi = " --without-headers --with-newlib"
# gcc 4.7 needs -isystem
export ARCH_FLAGS_FOR_TARGET = "--sysroot=${STAGING_DIR_TARGET} -isystem=${target_includedir}"
diff --git a/meta/recipes-devtools/gcc/gcc-runtime.inc b/meta/recipes-devtools/gcc/gcc-runtime.inc
index 9e39d49d14..4839a6687a 100644
--- a/meta/recipes-devtools/gcc/gcc-runtime.inc
+++ b/meta/recipes-devtools/gcc/gcc-runtime.inc
@@ -281,7 +281,7 @@ SUMMARY:libitm-staticdev = "GNU transactional memory support library - static de
require gcc-testsuite.inc
-EXTRA_OEMAKE:prepend_task-check = "${PARALLEL_MAKE} "
+EXTRA_OEMAKE:prepend:task-check = "${PARALLEL_MAKE} "
MAKE_CHECK_TARGETS ??= "check-gcc ${@" ".join("check-target-" + i for i in d.getVar("RUNTIMETARGET").split())}"
# prettyprinters and xmethods require gdb tooling
diff --git a/meta/recipes-devtools/gdb/gdb-common.inc b/meta/recipes-devtools/gdb/gdb-common.inc
index 01cca123f8..0fe7b4e5b0 100644
--- a/meta/recipes-devtools/gdb/gdb-common.inc
+++ b/meta/recipes-devtools/gdb/gdb-common.inc
@@ -59,7 +59,7 @@ do_install:append() {
rm -f ${D}${infodir}/bfd.info
}
-RRECOMMENDS:gdb:append_linux = " glibc-thread-db "
-RRECOMMENDS:gdb:append_linux-gnueabi = " glibc-thread-db "
-RRECOMMENDS:gdbserver:append_linux = " glibc-thread-db "
-RRECOMMENDS:gdbserver:append_linux-gnueabi = " glibc-thread-db "
+RRECOMMENDS:gdb:append:linux = " glibc-thread-db "
+RRECOMMENDS:gdb:append:linux-gnueabi = " glibc-thread-db "
+RRECOMMENDS:gdbserver:append:linux = " glibc-thread-db "
+RRECOMMENDS:gdbserver:append:linux-gnueabi = " glibc-thread-db "
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 8ebd7d7cb5..f473272096 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -110,7 +110,7 @@ EXTRA_OEMAKE += "\
# that it has to be done this way rather than by passing -j1, since
# perf's build system by default ignores any -j argument, but does
# honour a JOBS variable.
-EXTRA_OEMAKE:append_task-configure = " JOBS=1"
+EXTRA_OEMAKE:append:task-configure = " JOBS=1"
PERF_SRC ?= "Makefile \
tools/arch \