summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-02-05 11:44:00 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-07 17:29:44 +0000
commit839eebceecf33d106592bab154481486533ece75 (patch)
tree41bcc10dc0c119e2fd87861aa0edc706efe35dd0
parent1e43b836106ed13cde294e2c565eaea6fe5efca7 (diff)
downloadopenembedded-core-839eebceecf33d106592bab154481486533ece75.tar.gz
libpcre: enable unicode properties by default
Enable Unicode properties by default, as they're useful and for example GLib needs them. As there is an impact to code size add this as a PACKAGECONFIG so tightly constrained environments can save space by potentially disabling them. Also change --enable-utf8 to --enable-utf, as the former is a compatibility option for the latter. Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-support/libpcre/libpcre_8.38.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-support/libpcre/libpcre_8.38.bb b/meta/recipes-support/libpcre/libpcre_8.38.bb
index 4f31f8c4c8..384c2fe79c 100644
--- a/meta/recipes-support/libpcre/libpcre_8.38.bb
+++ b/meta/recipes-support/libpcre/libpcre_8.38.bb
@@ -22,12 +22,13 @@ S = "${WORKDIR}/pcre-${PV}"
PROVIDES += "pcre"
DEPENDS += "bzip2 zlib"
-PACKAGECONFIG ??= "pcre8"
+PACKAGECONFIG ??= "pcre8 unicode-properties"
PACKAGECONFIG[pcre8] = "--enable-pcre8,--disable-pcre8"
PACKAGECONFIG[pcre16] = "--enable-pcre16,--disable-pcre16"
PACKAGECONFIG[pcre32] = "--enable-pcre32,--disable-pcre32"
PACKAGECONFIG[pcretest-readline] = "--enable-pcretest-libreadline,--disable-pcretest-libreadline,readline,"
+PACKAGECONFIG[unicode-properties] = "--enable-unicode-properties,--disable-unicode-properties"
BINCONFIG = "${bindir}/pcre-config"
@@ -36,7 +37,7 @@ inherit autotools binconfig-disabled ptest
EXTRA_OECONF = "\
--enable-newline-is-lf \
--enable-rebuild-chartables \
- --enable-utf8 \
+ --enable-utf \
--with-link-size=2 \
--with-match-limit=10000000 \
"