summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-08-27 14:24:36 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-09-01 14:05:41 +0100
commite2e87d82ad1ec071077f29613e2e568196912daa (patch)
tree5bcee2fd81efa710e550b2d4a9e8e4f83ee10e0c
parent28aaf1223396820f8fcd9a6aade46b5007b030a6 (diff)
downloadopenembedded-core-e2e87d82ad1ec071077f29613e2e568196912daa.tar.gz
rust: fix upstream version checks
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/rust/rust-source.inc3
-rw-r--r--meta/recipes-example/rust-hello-world/rust-hello-world_git.bb2
2 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rust/rust-source.inc b/meta/recipes-devtools/rust/rust-source.inc
index 52502fb49f..1529ecfafe 100644
--- a/meta/recipes-devtools/rust/rust-source.inc
+++ b/meta/recipes-devtools/rust/rust-source.inc
@@ -1,3 +1,6 @@
SRC_URI += "https://static.rust-lang.org/dist/rustc-${PV}-src.tar.xz;name=rust"
RUSTSRC = "${WORKDIR}/rustc-${PV}-src"
+
+UPSTREAM_CHECK_URI = "https://forge.rust-lang.org/infra/other-installation-methods.html"
+UPSTREAM_CHECK_REGEX = "rustc-(?P<pver>\d+(\.\d+)+)-src"
diff --git a/meta/recipes-example/rust-hello-world/rust-hello-world_git.bb b/meta/recipes-example/rust-hello-world/rust-hello-world_git.bb
index c29eac34e5..3ebd9cc661 100644
--- a/meta/recipes-example/rust-hello-world/rust-hello-world_git.bb
+++ b/meta/recipes-example/rust-hello-world/rust-hello-world_git.bb
@@ -8,6 +8,8 @@ SRC_URI += "\
file://0001-enable-LTO.patch \
"
+UPSTREAM_CHECK_COMMITS = "1"
+
SUMMARY = "Hello World by Cargo for Rust"
HOMEPAGE = "https://github.com/meta-rust/rust-hello-world"
LICENSE = "MIT | Apache-2.0"