summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-26 14:32:28 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-26 22:59:59 +0000
commite6885069e2af833ebacfd33a04147b095af92d20 (patch)
tree5308391356356429ca784a1a9e248bc6f9b1df05
parent4482af07df26644885bae49b98f5d765a5caa68c (diff)
downloadopenembedded-core-e6885069e2af833ebacfd33a04147b095af92d20.tar.gz
beecrypt: Add PACKAGECONFIG for cplusplus
Add a PACKGECONFIG to control the building of the beecrypt C++ bindings. The only user of beecrypt in OE-Core is rpm and this doesn't need the C++ bindings so default the option to be off. This means we can lose the icu dependency by default which is a significant performance win. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/beecrypt/beecrypt_4.2.1.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-support/beecrypt/beecrypt_4.2.1.bb b/meta/recipes-support/beecrypt/beecrypt_4.2.1.bb
index 0a8ff4bc56..a917201023 100644
--- a/meta/recipes-support/beecrypt/beecrypt_4.2.1.bb
+++ b/meta/recipes-support/beecrypt/beecrypt_4.2.1.bb
@@ -16,8 +16,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=9894370afd5dfe7d02b8d14319e729a1 \
file://COPYING.LIB;md5=dcf3c825659e82539645da41a7908589 \
file://include/beecrypt/beecrypt.h;endline=20;md5=47a93eef539aac237eef86297a4d71c1"
-DEPENDS = "icu"
-
PR = "r3"
inherit autotools multilib_header
@@ -29,6 +27,9 @@ do_install_append() {
EXTRA_OECONF="--without-python --enable-shared --enable-static --disable-openmp --with-java=no"
+PACKAGECONFIG = ""
+PACKAGECONFIG[cplusplus] = "--with-cplusplus,--without-cplusplus,icu"
+
FILES_${PN} = "${sysconfdir} ${libdir}/*.so.* ${libdir}/${BPN}/*.so.*"
FILES_${PN}-dev += "${libdir}/${BPN}/*.so ${libdir}/${BPN}/*.la"
FILES_${PN}-staticdev += "${libdir}/${BPN}/*.a"